Failing to run integration tests for opensearch-py repo

Versions (relevant - OpenSearch/Dashboard/Server OS/Browser):
Opensearch - py repo
Python 3.10.10 (tags/v3.10.10:aad5f6a, Feb 7 2023, 17:20:36) [MSC v.1929 64 bit (AMD64)] on win32
Docker Desktop 4.17.1 (101757) On Windows 10

Describe the issue:

I tried to run the integration tests command line “./.ci/run-tests true 1.3.0” on Git Bash terminal, but it is failing with the message:
“INFO: Take down node if called twice with the same arguments (DETACH=true) or on seperate terminals .ci/ line 13: opensearch_node_name: unbound variable”

What have I done to tackle the issue?:

I tried to run the command on different terminals (cmd, PowerShell) and tried to declare the variable opensearch_node_name as the location of the docker container in .ci/functions/ No results.

Relevant Logs or Screenshots:

I think problem with the shell script. The error message indicates that the variable opensearch node name is not specified resulting in the script failing. You might try checking to see if the variable is declared in the script file. ci/ If it`s not declared in the script, you could try declare it before running the script.

Yea, I already tried to declare it as a name of the docker container in and run-opensearch, but it’s still failing with the same message.

I also tried fixing it using
script_path=$(dirname $(realpath -s $0 | tr ‘\’ ‘/’))
instead of:
script_path=$(dirname $(realpath -s $0))
inside .ci/ and .ci/
thinking the $0 variable may contain a path with backslashes, which can cause issues with the realpath command (credits to @nurovich14 )

But it also did not help.

Has the error been updated or is the terminal displaying the same message?

Yes, it’s failing with the same message.