Empty contents for Official Kibana Discover/Visualize

I tried to install the open distro for elasticsearch + kibana, the plugins security/alerting/tenants are there but the official contents are all empty. Is it normal ?
I can’t use Discover, Visualize, Management, Dev Tools.

EDIT : The url has a #, is it normal? /app/kibana#/discover
It’s normal.
OK it’s empty until you add some data, you can add the index in kibana, security audit thing.

Thanks for all the work though, seems really interesting.


Hiya - how are you installing? Can you share your installation steps so we can reproduce?


Hey !
I downloaded the RPM, then yum install on my RedHat server (not connected to internet).
All the pages of basic contents were empty until I added the kibana index.
In management section, there is still no elasticsearch management thing, like I used to have in official Elastic Stack.

EDIT : All the pages are back to white, no more index management.

I am trying to setup logstash to send some data, searching how to set it up with open distro for elasticsearch.


I tried to uninstall everything, yum remove opendistroforelasticsearch / -kibana / elasticsearch-oss and the plugins. Then i re-installed everything, now I am stuck on Kibana status page after logging in with an error “Tenant migration failed”. In the logs, Kibana Migrator is not defined".


Here the kibana.log

Thank you

EDIT : Ok I fixed the error of tenant migration failed.
Check here : https://forum.opensearch.org/t/about-tenant-indices-migration-failed-error-in-kibana/138/2?u=thibaudf

I’m back to white pages for every thing but Timelion, Alerting, Security & Tenants.


Thanks for reporting this.

You should be able to use Discover, Visualize, Management, Dev Tools etc as usual.
For example:

Can you please check and share if there are any error messages in your browser’s console or Kibana logs or elasticsearch.log?

Hello !
Found out this error in the console when I’m browsing the pages, still all white.

Also this,

no window definitions match http://bjpisstilloffline:5601/app/kibana#/discover?_g=()

About elasticsearch.log :

[2019-03-15T10:09:12,904][ERROR][c.a.o.e.p.h.NetworkE2E   ] [RoNCTVx] java.io.FileNotFoundException: /proc/net/tcp6 (No such file or directory)
java.io.FileNotFoundException: /proc/net/tcp6 (No such file or directory)
        at java.io.FileInputStream.open0(Native Method) ~[?:?]
        at java.io.FileInputStream.open(FileInputStream.java:219) ~[?:?]
        at java.io.FileInputStream.<init>(FileInputStream.java:157) ~[?:?]
        at java.io.FileReader.<init>(FileReader.java:75) ~[?:?]
        at com.amazon.opendistro.elasticsearch.performanceanalyzer.hwnet.NetworkE2E.mapTCPMetrics(NetworkE2E.java:128) [opendistro_performance_analyzer-]
        at com.amazon.opendistro.elasticsearch.performanceanalyzer.hwnet.NetworkE2E.mapTCPMetrics(NetworkE2E.java:144) [opendistro_performance_analyzer-]
        at com.amazon.opendistro.elasticsearch.performanceanalyzer.hwnet.NetworkE2E.addSample(NetworkE2E.java:201) [opendistro_performance_analyzer-]
        at com.amazon.opendistro.elasticsearch.performanceanalyzer.metrics_generator.linux.LinuxTCPMetricsGenerator.addSample(LinuxTCPMetricsGenerator.java:65) [opendistro_performance_analyzer-]
        at com.amazon.opendistro.elasticsearch.performanceanalyzer.collectors.NetworkE2ECollector.collectMetrics(NetworkE2ECollector.java:38) [opendistro_performance_analyzer-]
        at com.amazon.opendistro.elasticsearch.performanceanalyzer.collectors.PerformanceAnalyzerMetricsCollector.lambda$run$0(PerformanceAnalyzerMetricsCollector.java:57) [opendistro_performance_analyzer-]
        at com.amazon.opendistro.elasticsearch.performanceanalyzer.PerformanceAnalyzerPlugin.lambda$invokePrivileged$1(PerformanceAnalyzerPlugin.java:104) [opendistro_performance_analyzer-]
        at java.security.AccessController.doPrivileged(Native Method) [?:?]
        at com.amazon.opendistro.elasticsearch.performanceanalyzer.PerformanceAnalyzerPlugin.invokePrivileged(PerformanceAnalyzerPlugin.java:102) [opendistro_performance_analyzer-]
        at com.amazon.opendistro.elasticsearch.performanceanalyzer.collectors.PerformanceAnalyzerMetricsCollector.run(PerformanceAnalyzerMetricsCollector.java:57) [opendistro_performance_analyzer-]
        at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1128) [?:?]
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:628) [?:?]
        at java.lang.Thread.run(Thread.java:834) [?:?]

Thanks for trying to help me!

Thanks for reporting the issue. Curious: if you have disabled IPv6 in your environment. Regardless, this FileNotFoundException shouldn’t block the functionality, as we have absorbed this error in cases like IPv6 not enabled.

Alright, I managed to figure it out !
If you are in global tenant mode, every thing is white !
I went back to private or create some custom ones and every thing is fine now.
Is it normal to have nothing in global mode ? The security audit things only linked to private tenant right?

By the way, I wonder why the elasticsearch part in the management section was removed?

I like to clean up my elasticsearch indexes, remove or do stuff on the UI. Am I force to only use the Elasticsearch API?

Thank you.

Hi @ThibaudF,

The reason you don’t see Elasticsearch part in the Management tab is that this is a licensed feature covered by Elastic’s free Basic license. ODE does not support it.

I have tried to install ODE’s security plugin on a Basic license Kibana but failed. The option is to have two separate Kibanas - one secured by ODE for your users and second one with extra features just for you.


1 Like

Thank you for the quick answer.
I understand, I hope we can get this UI too because it helps a lot :smile: .


Hi Thi,

We are thinking about adding this feature as part of the Index Management RFC we have posted here: https://github.com/opendistro-for-elasticsearch/index-management/blob/master/RFC.md

This RFC also covers a full Index State Management feature and we are thinking it will include an admin panel for manual index manipulation.

Please feel free to review and provide your feedback on GitHub.


1 Like

Hey Carl, thank you for this, I will read it.

By the way, I still have all white pages for Global Tenant, I don’t know what is wrong with my installation…
I use custom tenants instead.

EDIT : Cleaned up the install and now Global Tenant working !
Might have some corrupt files…

Thank you for the help!


Are you saying, after cleanup the install, you are not seeing “java.io.FileNotFoundException: /proc/net/tcp6 (No such file or directory)” error?

No I still see this error about /proc/net/tcp6 because IPv6 is disabled yes. I don’t mind as long as elastic is working normally.

I meant that the Global Tenant is now working, no more white pages.
New problem I faced is that restoring the yml files, the configuration, tenants with the accounts who had CRUD on their indexes lost all their rights,

[2019-03-20T17:47:01,790][INFO ][c.a.o.s.p.PrivilegesEvaluator] [g3XXT-5] No index-level perm match for User [name=test, roles=[], requestedTenant=DOI] Resolved [aliases=[.kibana_67870_doi], indices=[], allIndices=[.kibana_67870_doi_2], types=[doc], isAll()=false, isEmpty()=false] [Action [indices:data/write/bulk[s]]] [RolesChecked [own_index, test_rw]]
[2019-03-20T17:47:01,790][INFO ][c.a.o.s.p.PrivilegesEvaluator] [g3XXT-5] No permissions for [indices:data/write/index, indices:data/write/bulk[s]]

My only work around is to delete manually all tenants and create them again.


I figured this one out for my situation. I don’t see it explicitly documented here. So, for others that land here looking for a similar error to:
No index-level perm match for User [name=CN=New-User,OU=Somewhere,OU=Users,OU=Something,DC=domain,DC=com, roles=[New-User-Role, Employees], requestedTenant=null] Resolved [aliases=[.kibana], indices=[], allIndices=[.kibana_2], types=[*], isAll()=false, isEmpty()=false] [Action [indices:data/read/search]] [RolesChecked [own_index]]

For me, the solution was to give the New-User-Role access to the Rest API in elasticsearch.yml.
opendistro_security.restapi.roles_enabled: ["all_access", "security_rest_api_access", "New-User-Role"]

and, map roles to AD/LDAP:
opendistro_security.roles_mapping_resolution: BOTH

Afterwards, I restarted elasticsearch, then reloaded the configuration using securityadmin.sh

1 Like

I’ve had all-white pages when I had previously signed in to Kibana and then changed my credentials for the admin user. I fixed by logging out of Kibana (with the logout button) and logging back in. Your browser caches the credentials, and they need to be cleared.

Seems like this is not your issue, but maybe helpful to others.

Hi there,

I’m also experiencing the same issue whenever I restart the docker container. Note, I’m also providing a customized elasticsearch.yml to the setup which also contains i.e opendistro_security.restapi.roles_enabled: ["all_access", "security_rest_api_access"] and not specifying the new roles created after the initial setup and then those roles are mapped to the tenant. The strange thing is that whenever it gets restarted, users switched to that tenant can’t see/view saved objects (index- patterns, dashboards) and when trying to view the indices via Discover panel it is only an Empty view. The only solution was to create another tenant and import all these Saved Objects there but this doesn’t’ sound like a great solution as the cluster can get restarted often (running on docker nodes).

Did someone experience the same issue? and is there a solution besides creating a new tenant?

PS: When login via admin user and switched to that tenant, I can see the dashboards and view the Discover panel but not with the user who belongs to that role–>tenant.

Many thanks in advance for your help.

Thanks a lot, @mattsdevop, I was missing this part on my configuration. When we set this to map to BOTH AD/internal, it works.

Best regards,