Email notifications not sent

I am trying to set up sending email alerts.
I created a sender and a receiver, registered an SNMP host and port, but sending does not work.
I tried to point the sender account to the Elasticsearch keystore using the command:
/ usr / share / elasticsearch / bin / elasticsearch-keystore add, but I get the error:
ERROR: Setting name [] does not match the allowed setting name pattern [[A-Za-z0-9 _ \ -.] +]
Can you please tell me what I am doing wrong and how to resolve the issue?

OK. Interesting. I see .ru in your address - do you have cyrillic in your username?

No, the domain is in English. Just in the .ru domain zone.

Humm. It really looks some sort of disallowed character is in the username setting.

And tell me, please, when we give the command:
/ usr / share / elasticsearch / bin / elasticsearch-keystore add
Is it correct what I am specifying in the address to the mail command?
Also, after entering the command, the system asks for another value. What then needs to be entered?
And do you need to designate the mail account somewhere else?

OH! I see the problem. You don’t actually put your email address inside the setting name - that’s what the prompt is for. You define your sender in the GUI with a sender name - this is really an identifier for the sender. Example, if in the GUI you defined the sender name as zarina you’d run:

$ elasticsearch-keystore add

Then when it prompts you’d enter

You’ll need to handle the password in a similar way.


Many thanks!
I will try

It turns out that for mailing you only need to add a user to the keystore and register the sender’s settings in the GUI?
Do you need to designate the user somewhere else, for example in internal_users.yml?

There is progress, if I may say so :slight_smile:
After specifying the mail settings, the following error appeared

OK - troubleshooting at a distance is tough but that error message comes from the buildURI method and is (in the mailing context) is being called from getURI which is only passing host and port - have you specified your mail server host and port?

Yes, host and port are listed, but I think the values ​​are wrong. And most likely, the real error appears.
When trying to send a test message, I also noticed such a message in the developer console (Google Chrome)Снимок

Could it be the missing SSL?

The devtools error is unrelated AFAIK - that message is coming from Java, so wouldn’t bubble up through the frontend.