Dashboard doesn't play well with LastPass

This one was a head-banger. Mostly posting here in case other people have run into the same problem and save them some head-banging of their own.

I was trying to change an internal user’s password. I would go to Security / Internal users and click on the user I wanted to change. I’d get to the “Edit internal user” screen but the username was pre-filled with “admin” instead the selected user. Eventually I noticed it was filling with the right username and then a fraction of a second later, it would change to “admin”, but it was greyed out and wouldn’t let me change it back.

To make a long story short, it was LastPass autofilling the form. The username box is <input type="text" ... disabled> but I guess LastPass does some DOM manipulation which doesn’t honor that.

Not sure if there’s anything that can be done on the dashboard side to prevent this, but the workaround is to go into the LastPass “Advanced Settings” and check “Disable Autofill” for that item.