Can't delete a monitor

OpenSearch 2.6.0

When trying to delete monitor from dashboards, getting this exception

[alerting_exception] The provided URL and URI fields form different URLs.

Hi @stecino. Have you tried using the API?

@stecino I’ve just tested 2.6.0, 2.8.0 and 2.9.0.

I’ve created a simple alert against the security index (no triggers or actions).

Deleting this monitor in 2.6.0 and 2.8.0 produced a similar error in the OpenSearch Dashboards.

However, as per the screenshot, the monitor has been deleted.

In 2.9.0 it has been deleted successfully.

I’ve checked the release notes of OpenSearch 2.9.0 and found a fix regarding the monitors. Maybe this fix also resolved the issue of failing to delete monitors.

Have you tried to clear the content of the reported monitor to a very basic level and delete it then?

I tried to, but when I try to look for the monitor it doesn’t seem to be there? But it shows in the UI

I will most likely upgrade to 2.9.0, I wanted to anyways

@pablo this issue is specific to dashboards, or Opensearch? Another words, can I upgrade one and not the other?

@stecino Monitors are part of the Alerting plugin, so the issue should regard only the OpenSearch Dashboards.

Why would you want to mix OpenSearch and OpenSearch Dashboards versions?

I don’t want to, since I was going to upgrade the Opensearch first, I wanted to know if lower version of Dashboards will still work with higher version of Opensearch, until I upgrade that as well