Build failed ./gradlew assemble

Versions (relevant - OpenSearch/Dashboard/Server OS/Browser):

Describe the issue:
a problem occurred while using Docker from [C:\Program Files\Docker\Docker\resources\bin\docker.exe] yet it is required to run the following tasks:


Relevant Logs or Screenshots:

To run Opensearch, you need the image running in the docker.
Check if the docker is running. Reinstall if there is an error.

I had similar problem with this command. Maybe you should also check your java_home variables and their path in terminal. After I downloaded and set them, everything worked. Maybe this video guide from YouTube would help Introduction to the OpenSearchCore Install - YouTube

Check and try this solution

yes the problem was that the docker was not running

You did a great job! Glad to have been of help! :wink:

1 Like

but I have one problem I can’t find the extension.yml in distribution/archives/linux-tar/build

1 Like

Please mark the solution if the topic is closed :v:

try make build with plugin param

./ -Dplugins=opensearch-ml
  • CategoryInfo : ObjectNotFound: (./ , CommandNotFoundException
    • FullyQualifiedErrorId : CommandNotFoundException

This command must be run inside the cloned repository

/c/openSearch/opensearch (main)
$ ./ -Dplugins=opensearch-ml
bash: ./ No such file or directory

I’ll be on the computer tomorrow and try to find the answer.

I still haven’t been able to solve this problem,do u remember about me?

Yes, I remember, not at home now. No chance to fiddle with the code :blush: is inside scripts folder. You can either cd into that folder or run ./scripts/ -Dplugins=opensearch-ml

cd scripts && ./ -Dplugins=opensearch-ml

Actually, I ran the scripts inside the folder, however I don’t find the file extension.yml

I was able to run successfully on the latest changes in main:

./scripts/ -v 3.0.0 -q '' -s false

Can you please list the steps to reproduce the issue that you are facing?