Authentication and Authorization 404 error - page not loading

I am currently running 6.8.1 ES and Kibana with the Opendistro security plugin installed for both. I am using the local admin account for testing. The issue is that when I attempt to access Security → Authentication and Authorization, nothing on that page loads and the browser console shows 404 errors.

I also get errors in the Security page. Here is what the console looks like with all the 400 errors

I am currently using the following kibana.yml, elasticsearch.yml, and opendistro security plugin yml files as follows:
kibana.yml false
# Copyright <2019>, Inc. or its affiliates. All Rights Reserved.
# Licensed under the Apache License, Version 2.0 (the "License").
# You may not use this file except in compliance with the License.
# A copy of the License is located at
# or in the "license" file accompanying this file. This file is distributed
# express or implied. See the License for the specific language governing
# permissions and limitations under the License.

# Release Note:
# Default Kibana configuration for Open Distro. ""
elasticsearch.ssl.verificationMode: none
elasticsearch.username: kibanaserver
elasticsearch.password: kibanaserver
elasticsearch.requestHeadersWhitelist: ["securitytenant","Authorization"]

opendistro_security.multitenancy.enabled: false
#opendistro_security.multitenancy.tenants.preferred: ["Private", "Global"]
opendistro_security.readonly_mode.roles: ["kibana_read_only"]

elasticsearch.yml false ELK
cluster.max_shards_per_node: 20000 ${HOSTNAME}
node.attr.box_type: hot
node.master: true /home/elasticsearch
path.logs: /var/log/elasticsearch
        core: 1
        max: 6
        keep_alive: 2m ["", ""]
opendistro_security.advanced_modules_enabled: true
opendistro_security.allow_unsafe_democertificates: false
opendistro_security.audit.type: internal_elasticsearch
opendistro_security.enable_snapshot_restore_privilege: true
opendistro_security.check_snapshot_restore_write_privileges: true
opendistro_security.restapi.roles_enabled: ["all_access","security_rest_api_access"]
cluster.routing.allocation.disk.threshold_enabled: false
discovery.zen.minimum_master_nodes: 1
node.max_local_storage_nodes: 3
opendistro_security.ssl.transport.pemcert_filepath: hostname.pem
opendistro_security.ssl.transport.pemkey_filepath: hostname.key
opendistro_security.ssl.transport.pemtrustedcas_filepath: root-ca.pem
opendistro_security.ssl.transport.enforce_hostname_verification: false
opendistro_security.ssl.transport.resolve_hostname: true
opendistro_security.ssl.http.enabled: true
opendistro_security.ssl.http.pemcert_filepath: hostname_http.pem
opendistro_security.ssl.http.pemkey_filepath: hostname_http.key
opendistro_security.ssl.http.pemtrustedcas_filepath: root-ca.pem
  - "TLSv1.1"
  - "TLSv1.2"
- -"CN=*,OU=Ops,O=hostname Net\\, Inc.,DC=hostname,DC=com"
-,OU=Ops,O=hostname com\, Inc.,DC=hostname,DC=com
-,OU=Ops,O=hostname com\, Inc.,DC=hostname,DC=com
-,OU=Ops,O=hostname com\, Inc.,DC=hostname,DC=com

opendistro_security.roles_mapping_resolution: BOTH

The opendistro security plugin configurations I’m using are directly from security/securityconfig at opendistro-0.10 · opendistro-for-elasticsearch/security · GitHub

I’ve reviewed all the permissions/configurations and I can’t see anything that stands out as an issue. Especially since it’s pretty much a vanilla configuration/install.

Bump. Can anyone help?

In the mean time, I have tried modifying the opendistro_security.restapi.roles_enabled to include only “all_access”. This changes the behavior of the Security tab as I am only able to access the tab, but no icons are shown.

Crossposted to this similar issue: Session.ttl is ignored with SAML Integration · Issue #15 · opendistro-for-elasticsearch/security-kibana-plugin · GitHub

I went a bit further and tried adding different things to the security configuration without success. I attempted to reach the URL directly to see if it was available. I reach a 404 message just like the console indicates. I’m starting to believe something is missing from what Kibana/opendistro is looking for, rather than this being a permissions thing.

Not even sure what to try at this point, but I haven’t given up

This has the unintended, but desirable, result of blocking other users from viewing sensitive information.

@mattsdevop have you got it resolved?
Trying to understand your scenario. You’ve installed opendistro security plugin on original Elasticsearch and Kibana?