Alert Custom Webhook:Jira Service Desk


I’m trying to send an alert to Jira Service Desk as an Incident, but keep getting a “400 Bad Request” error.

Any pointers would be truly appreciated. :pray:

The destination configuration:

The alert action message:

“serviceDeskId”: “5”,
“requestTypeId”: “165”,
“requestFieldValues”: {
“summary”: “Test”,
“components”: [
“id”: “18468”
“priority”: {
“id”: “4”
“labels” : [“burn-in”, “application-errors”]

Maybe there’s typo in the Mustache script I’m not seeing?

Again, TIA!

Can you curl it from the cluster?

Could provide more details? Whats the error from the logs?

Getting a http 400 (bad request) error. It’s the same payload I’m using the generate a Jira issue via a different monitoring system and it’s working there, so it’s quite baffling. TIA for any help. Cheers.

Error: Failed running action: Failed: HttpResponseProxy{HTTP/1.1 400 Bad Request [Server: AtlassianProxy/, cache-control: no-cache, no-store, no-transform, Content-Type: application/json;charset=UTF-8, Strict-Transport-Security: max-age=315360000; includeSubDomains; preload, Date: Thu, 11 Mar 2021 21:37:17 GMT, ATL-TraceId: f5f9ef3c3a325e61, x-arequestid: b606c2cd-7fb5-4ff4-8936-db535282fcdb, x-aaccountid: 5d5de754d388c80ca1b7361a, X-XSS-Protection: 1; mode=block, Transfer-Encoding: chunked, timing-allow-origin: *, x-envoy-upstream-service-time: 36, X-Content-Type-Options: nosniff, micros-issuer: micros/edge-authenticator, Connection: close, Expect-CT: report-uri=“”, enforce, max-age=86400] ResponseEntityProxy{[Content-Type: application/json;charset=UTF-8,Chunked: true]}}

@lonehawk Are you able to use CURL from ODFE system and send the request?

I’m an idiot. It’s fixed now. I rebuilt the payload and found that I was missing a comma in my original one that was giving me a 400 error. :roll_eyes:

Thanks for your help and sorry for the false alarm. LOL

@lonehawk Not a problem.