# Yum Update Dependency Error

**URL:** https://forum.opensearch.org/t/yum-update-dependency-error/337
**Category:** General Feedback
**Created:** [April 2, 2019, 9:14am UTC](https://forum.opensearch.org/t/yum-update-dependency-error/337 "2019-04-02T09:14:25Z")
**Posts on this page:** 5
**Page:** 1

<div class="post-metadata">

### Author: ![manicminer](https://avatars.discourse-cdn.com/v4/letter/m/dfb087/32.png) [@manicminer](https://forum.opensearch.org/u/manicminer)
#### Post date: [April 2, 2019, 9:14am UTC](https://forum.opensearch.org/t/yum-update-dependency-error/337/1 "2019-04-02T09:14:25Z")

</div>

Hi

Have a CentOS 7.6 vanilla install and installed OD 0.7.0 with no problem and all working as expected. Have tried to yum update and received the following:

> Finished Dependency Resolution  
> Error: Package: opendistro-security-0.7.0.1-1.noarch (opendistroforelasticsearch-artifacts-repo)  
> Requires: elasticsearch-oss = 6.5.4  
> Removing: elasticsearch-oss-6.5.4-1.noarch (@elasticsearch-6.x)  
> elasticsearch-oss = 6.5.4-1  
> Updated By: elasticsearch-oss-6.7.0-1.noarch (elasticsearch-6.x)  
> elasticsearch-oss = 6.7.0-1  
> Also for

Error: Package: opendistro-performance-analyzer-0.7.0.0-1.noarch (@opendistroforelasticsearch-artifacts-repo)  
Requires: elasticsearch-oss = 6.5.4

Error: Package: opendistro-alerting-0.7.0.0-1.noarch (@opendistroforelasticsearch-artifacts-repo)  
Requires: elasticsearch-oss = 6.5.4

Error: Package: opendistro-sql-0.7.0.0-1.noarch (@opendistroforelasticsearch-artifacts-repo)  
Requires: elasticsearch-oss = 6.5.4

Do I need to update a repo or settings or easier to start again with 0.7.1?

Regards

---

<div class="post-metadata">

### Author: ![zhoqingy](https://avatars.discourse-cdn.com/v4/letter/z/5fc32e/32.png) [@zhoqingy](https://forum.opensearch.org/u/zhoqingy)
#### Post date: [April 3, 2019, 12:28am UTC](https://forum.opensearch.org/t/yum-update-dependency-error/337/2 "2019-04-03T00:28:48Z")

</div>

Hi @manicminer  
Can you try to run ‘yum update opendistroforelasticsearch’ to update opendistroforelasticsearch. Thanks

---

<div class="post-metadata">

### Author: ![manicminer](https://avatars.discourse-cdn.com/v4/letter/m/dfb087/32.png) [@manicminer](https://forum.opensearch.org/u/manicminer)
#### Post date: [April 3, 2019, 9:03am UTC](https://forum.opensearch.org/t/yum-update-dependency-error/337/3 "2019-04-03T09:03:08Z")

</div>

Many thanks so that ran (output below) but not sure it has resolved the issue as re-running yum update displays the original errors:

> [root@opendistroes01 ~]# yum update opendistroforelasticsearch  
> Loaded plugins: fastestmirror  
> Loading mirror speeds from cached hostfile
> 
> - base: centos.
> - extras: mirror.
> - updates: mirror.  
> base | 3.6 kB 00:00  
> elasticsearch-6.x | 1.3 kB 00:00  
> extras | 3.4 kB 00:00  
> opendistroforelasticsearch-artifacts-repo/signature | 819 B 00:00  
> opendistroforelasticsearch-artifacts-repo/signature | 2.5 kB 00:00 !!!  
> updates | 3.4 kB 00:00  
> updates/7/x86\_64/primary\_db | 3.4 MB 00:01  
> Resolving Dependencies  
> → Running transaction check  
> —\> Package opendistroforelasticsearch.noarch 0:0.7.0-1 will be updated  
> —\> Package opendistroforelasticsearch.noarch 0:0.7.1-1 will be an update  
> → Processing Dependency: opendistro-security \>= 0.7.0.1 for package: opendistr oforelasticsearch-0.7.1-1.noarch  
> → Running transaction check  
> —\> Package opendistro-security.noarch 0:0.7.0.0-1 will be updated  
> —\> Package opendistro-security.noarch 0:0.7.0.1-1 will be an update  
> → Finished Dependency Resolution
> 
> Dependencies Resolved
> 
> # ================================================================================ Package Arch Version Repository Size
> 
> Updating:  
> opendistroforelasticsearch  
> noarch 0.7.1-1 opendistroforelasticsearch-artifacts-repo 2.7 k  
> Updating for dependencies:  
> opendistro-security  
> noarch 0.7.0.1-1 opendistroforelasticsearch-artifacts-repo 25 M
> 
> # Transaction Summary
> 
> Upgrade 1 Package (+1 Dependent package)
> 
> ## Total download size: 25 M Is this ok [y/d/N]: y Downloading packages: Delta RPMs disabled because /usr/bin/applydeltarpm not installed. (1/2): opendistroforelasticsearch-0.7.1.rpm | 2.7 kB 00:00:00 (2/2): opendistro-security-0.7.0.1.rpm | 25 MB 00:00:03
> 
> Total 7.1 MB/s | 25 MB 00:00:03  
> Running transaction check  
> Running transaction test  
> Transaction test succeeded  
> Running transaction  
> Updating : opendistro-security-0.7.0.1-1.noarch 1/4  
> OpenDistro for Elasticsearch Security Demo Installer  
> \*\* Warning: Do not use on production or public reachable systems \*\*  
> Basedir: /usr/share/elasticsearch  
> This script maybe require your root password for ‘sudo’ privileges  
> Elasticsearch install type: rpm/deb on CentOS Linux release 7.6.1810 (Core)  
> Elasticsearch config dir: /etc/elasticsearch  
> Elasticsearch config file: /etc/elasticsearch/elasticsearch.yml  
> Elasticsearch bin dir: /usr/share/elasticsearch/bin  
> Elasticsearch plugins dir: /usr/share/elasticsearch/plugins  
> Elasticsearch lib dir: /usr/share/elasticsearch/lib  
> Detected Elasticsearch Version: x-content-6.5.4  
> Detected Open Distro Security Version: 0.7.0.1  
> /etc/elasticsearch/elasticsearch.yml seems to be already configured for Security. Quit.  
> Updating : opendistroforelasticsearch-0.7.1-1.noarch 2/4  
> Cleanup : opendistroforelasticsearch-0.7.0-1.noarch 3/4  
> Cleanup : opendistro-security-0.7.0.0-1.noarch 4/4  
> Verifying : opendistroforelasticsearch-0.7.1-1.noarch 1/4  
> Verifying : opendistro-security-0.7.0.1-1.noarch 2/4  
> Verifying : opendistro-security-0.7.0.0-1.noarch 3/4  
> Verifying : opendistroforelasticsearch-0.7.0-1.noarch 4/4
> 
> Updated:  
> opendistroforelasticsearch.noarch 0:0.7.1-1
> 
> Dependency Updated:  
> opendistro-security.noarch 0:0.7.0.1-1
> 
> Complete!

---

<div class="post-metadata">

### Author: ![zhoqingy](https://avatars.discourse-cdn.com/v4/letter/z/5fc32e/32.png) [@zhoqingy](https://forum.opensearch.org/u/zhoqingy)
#### Post date: [April 3, 2019, 4:07pm UTC](https://forum.opensearch.org/t/yum-update-dependency-error/337/4 "2019-04-03T16:07:04Z")

</div>

yum update will update elasticsearch version. The opendistroforelasticsearch is distributed for a specific version of elasticsearch for each release. That is why yum update will have error msg since it is trying to update elasticsearch version.

---

<div class="post-metadata">

### Author: ![manicminer](https://avatars.discourse-cdn.com/v4/letter/m/dfb087/32.png) [@manicminer](https://forum.opensearch.org/u/manicminer)
#### Post date: [April 3, 2019, 4:28pm UTC](https://forum.opensearch.org/t/yum-update-dependency-error/337/5 "2019-04-03T16:28:02Z")

</div>

Ok then, so in order to update the OS successfully any references to ES/Kibana etc need to be excluded from the yum directive? If this is the case, at which point can (should) the OSS ES be updated ?

Many thanks for the clarification - will wait a while and see how things progress!

Regards
