# Unable to use beats on 1.0.0

**URL:** https://forum.opensearch.org/t/unable-to-use-beats-on-1-0-0/1049
**Category:** Open Source Elasticsearch and Kibana
**Created:** [July 4, 2019, 5:51am UTC](https://forum.opensearch.org/t/unable-to-use-beats-on-1-0-0/1049 "2019-07-04T05:51:16Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![oss1](https://avatars.discourse-cdn.com/v4/letter/o/8797f3/32.png) [@oss1](https://forum.opensearch.org/u/oss1)
#### Post date: [July 4, 2019, 5:51am UTC](https://forum.opensearch.org/t/unable-to-use-beats-on-1-0-0/1049/1 "2019-07-04T05:51:16Z")

</div>

I have installed the latest 1.0.0 version of elasticsearch via docker and elasticsearch and kibana work without errors. When I try to use any OSS beat with the default admin user I get the following errors:

2019-07-03T22:48:38.334-0700 ERROR instance/beat.go:802 Exiting: request checking for ILM availability failed: 500 Internal Server Error: {“error”:{“root\_cause”:[{“type”:“security\_exception”,“reason”:“Unexpected exception indices:admin/get”}],“type”:“security\_exception”,“reason”:“Unexpected exception indices:admin/get”},“status”:500}  
Exiting: request checking for ILM availability failed: 500 Internal Server Error: {“error”:{“root\_cause”:[{“type”:“security\_exception”,“reason”:“Unexpected exception indices:admin/get”}],“type”:“security\_exception”,“reason”:“Unexpected exception indices:admin/get”},“status”:500}

---

<div class="post-metadata">

### Author: ![oss1](https://avatars.discourse-cdn.com/v4/letter/o/8797f3/32.png) [@oss1](https://forum.opensearch.org/u/oss1)
#### Post date: [July 4, 2019, 8:41pm UTC](https://forum.opensearch.org/t/unable-to-use-beats-on-1-0-0/1049/2 "2019-07-04T20:41:42Z")

</div>

I have solved this by adding this to the beat config file:

setup.ilm.enabled: false

ILM seems to be an xpack feature and its not automatically disabled on OSS beats for some reason.

---

<div class="post-metadata">

### Author: ![ogulman](https://avatars.discourse-cdn.com/v4/letter/o/9fc29f/32.png) [@ogulman](https://forum.opensearch.org/u/ogulman)
#### Post date: [July 5, 2019, 1:31pm UTC](https://forum.opensearch.org/t/unable-to-use-beats-on-1-0-0/1049/3 "2019-07-05T13:31:19Z")

</div>

thanks a lot! It helps
