# Unable to run my transform job after updating to OpenSearch 2.11

**URL:** https://forum.opensearch.org/t/unable-to-run-my-transform-job-after-updating-to-opensearch-2-11/17650
**Category:** Index Management
**Tags:** troubleshoot
**Created:** [January 30, 2024, 10:41pm UTC](https://forum.opensearch.org/t/unable-to-run-my-transform-job-after-updating-to-opensearch-2-11/17650 "2024-01-30T22:41:37Z")
**Posts on this page:** 4
**Page:** 1

<div class="post-metadata">

### Author: ![bit64](https://avatars.discourse-cdn.com/v4/letter/b/d78d45/32.png) [@bit64](https://forum.opensearch.org/u/bit64)
#### Post date: [January 30, 2024, 10:41pm UTC](https://forum.opensearch.org/t/unable-to-run-my-transform-job-after-updating-to-opensearch-2-11/17650/1 "2024-01-30T22:41:37Z")

</div>

**Versions** (relevant - OpenSearch/Dashboard/Server OS/Browser):  
Currently on v2.11.  
Previously on v2.7.

**Describe the issue** :  
I currently have a transform job that I run periodically that used to run just fine on v2.7. Since upgrading to v2.11, the transform now fails with an error I have never seen before. I’ve had no issues running the transform aggregation without a proper field and only a script prior. If I add a bogus field to the aggregation, it runs just fine, but obviously without aggregating on the return value of the script. The aggregation still runs just fine outside of a transform in a normal search query.

**Configuration** :

```auto
POST _plugins/_transform/_preview
{
  "transform": {
    "enabled": true,
    "continuous": false,
    "schedule": {
      "interval": {
        "period": 1,
        "unit": "Minutes",
        "start_time": 1706576400000
      }
    },
    "description": "business metrics by S code.",
    "source_index": "crdb_2023_3",
    "target_index": "crdb_s_code_2023_9",
    "data_selection_query": {
      "match": {
        "business": "12345678"
      }
    },
    "page_size": 10,
    "groups": [
      {
        "terms": {
          "source_field": "ins_code.keyword",
          "target_field": "s_code"
        }
      }
    ],
    "aggregations": {
      "lien_avg": {
        "avg": {
            "script": {
              "lang": "painless",
              "source": """
              String val = doc[params.field].value;
              if (val != null && val.length() > 0)
              {
                double d_val = Double.parseDouble(val);
                if (d_val != 999 && d_val != 998)
                {
                  d_val
                }
                else
                {
                  null
                }
              }
              else
              {
                null;
              }
              """,
              "params": {
                "field": "lien.keyword"
              }
            }
          }
      }
    }
  }
}

```

**Relevant Logs or Screenshots** :

```auto
{
  "error": {
    "root_cause": [
      {
        "type": "status_exception",
        "reason": "Failed to parse the transformed results"
      }
    ],
    "type": "status_exception",
    "reason": "Failed to parse the transformed results",
    "caused_by": {
      "type": "null_pointer_exception",
      "reason": "sourceIdxFieldName must not be null"
    }
  },
  "status": 500
}

```

---

<div class="post-metadata">

### Author: ![gaobinlong](https://sea1.discourse-cdn.com/flex019/user_avatar/forum.opensearch.org/gaobinlong/32/5242_2.png) [@gaobinlong](https://forum.opensearch.org/u/gaobinlong)
#### Post date: [February 9, 2024, 7:46am UTC](https://forum.opensearch.org/t/unable-to-run-my-transform-job-after-updating-to-opensearch-2-11/17650/2 "2024-02-09T07:46:50Z")

</div>

Could you open an issue here:[Issues · opensearch-project/index-management · GitHub](https://github.com/opensearch-project/index-management/issues)?

---

<div class="post-metadata">

### Author: ![bit64](https://avatars.discourse-cdn.com/v4/letter/b/d78d45/32.png) [@bit64](https://forum.opensearch.org/u/bit64)
#### Post date: [February 9, 2024, 3:19pm UTC](https://forum.opensearch.org/t/unable-to-run-my-transform-job-after-updating-to-opensearch-2-11/17650/3 "2024-02-09T15:19:04Z")

</div>

Thanks for responding. Done.  
[Issue #1107](https://github.com/opensearch-project/index-management/issues/1107)

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/flex019/uploads/mauve_hedgehog/original/2X/3/33547ea01a5b12dcca2958411d3edd97ae2ea8c1.png) [@system](https://forum.opensearch.org/u/system)
#### Post date: [April 9, 2024, 3:19pm UTC](https://forum.opensearch.org/t/unable-to-run-my-transform-job-after-updating-to-opensearch-2-11/17650/4 "2024-04-09T15:19:06Z")

</div>

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.
