# Unable to launch Elastic Search in Rhel7 server after Installation

**URL:** <https://forum.opensearch.org/t/unable-to-launch-elastic-search-in-rhel7-server-after-installation/5772>\
**Category:** Open Source Elasticsearch and Kibana\
**Created:** [April 27, 2021, 4:57pm UTC](https://forum.opensearch.org/t/unable-to-launch-elastic-search-in-rhel7-server-after-installation/5772 "2021-04-27T16:57:27Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![bharathsharmaja](https://avatars.discourse-cdn.com/v4/letter/b/a3d4f5/32.png) [@bharathsharmaja](https://forum.opensearch.org/u/bharathsharmaja)\
**Post date:** [April 27, 2021, 4:57pm UTC](https://forum.opensearch.org/t/unable-to-launch-elastic-search-in-rhel7-server-after-installation/5772/1 "2021-04-27T16:57:28Z")

</div>

**Error Message :**  
Apr 26 06:18:39 choxxxxxxxxx systemd[1]: Starting Elasticsearch…

Apr 26 06:18:42 choxxxxxxxxx systemd-entrypoint[21064]: ERROR: Temporary file directory [“/elasticsearch/tmp”] does not exist or is not accessible

Apr 26 06:18:42 choxxxxxxxxx systemd[1]: elasticsearch.service: main process exited, code=exited, status=78/n/a

Apr 26 06:18:42 choxxxxxxxxx systemd[1]: Failed to start Elasticsearch.

**Full Error Log:-**

elasticsearch.service - Elasticsearch  
Loaded: loaded (/usr/lib/systemd/system/elasticsearch.service; enabled; vendor preset: disabled)  
Active: failed (Result: exit-code) since Tue 2021-04-27 11:55:20 CDT; 44s ago  
Docs: [https://www.elastic.co](https://www.elastic.co)  
Process: 6738 ExecStart=/usr/share/elasticsearch/bin/systemd-entrypoint -p ${PID\_DIR}/elasticsearch.pid --quiet (code=exited, status=1/FAILURE)  
Main PID: 6738 (code=exited, status=1/FAILURE)

Apr 27 11:55:20 choxxxxxxxxx systemd-entrypoint[6738]: Error: A fatal exception has occurred. Program will exit.  
Apr 27 11:55:20 choxxxxxxxxx systemd-entrypoint[6738]: at org.elasticsearch.tools.launchers.JvmOption.flagsFinal(JvmOption.java:119)  
Apr 27 11:55:20 choxxxxxxxxx systemd-entrypoint[6738]: at org.elasticsearch.tools.launchers.JvmOption.findFinalOptions(JvmOption.java:81)  
Apr 27 11:55:20 choxxxxxxxxx systemd-entrypoint[6738]: at org.elasticsearch.tools.launchers.JvmErgonomics.choose(JvmErgonomics.java:38)  
Apr 27 11:55:20 choxxxxxxxxx systemd-entrypoint[6738]: at org.elasticsearch.tools.launchers.JvmOptionsParser.jvmOptions(JvmOptionsParser.java:135)  
Apr 27 11:55:20 choxxxxxxxxx systemd-entrypoint[6738]: at org.elasticsearch.tools.launchers.JvmOptionsParser.main(JvmOptionsParser.java:86)  
Apr 27 11:55:20 choxxxxxxxxx systemd[1]: elasticsearch.service: main process exited, code=exited, status=1/FAILURE  
Apr 27 11:55:20 choxxxxxxxxx systemd[1]: Failed to start Elasticsearch.  
Apr 27 11:55:20 choxxxxxxxxx systemd[1]: Unit elasticsearch.service entered failed state.  
Apr 27 11:55:20 choxxxxxxxxx systemd[1]: elasticsearch.service failed.

**Steps Followed:**

**Step 1:**  
wget [https://artifacts.elastic.co/downloads/elasticsearch/elasticsearch-7.12.0-x86\_64.rpm](https://artifacts.elastic.co/downloads/elasticsearch/elasticsearch-7.12.0-x86_64.rpm)

**Step 2 :**  
rpm -Uhv elasticsearch-7.12.0-x86\_64.rpm

**Step 3:**  
systemctl daemon-reload

**Step 4:**  
sudo systemctl enable elasticsearch.service

**Step 5:**  
sudo systemctl start elasticsearch.service

---

<div class="post-metadata">

**Author:** ![jasonrojas](https://sea1.discourse-cdn.com/flex019/user_avatar/forum.opensearch.org/jasonrojas/32/4902_2.png) [@jasonrojas](https://forum.opensearch.org/u/jasonrojas)\
**Post date:** [April 27, 2021, 5:34pm UTC](https://forum.opensearch.org/t/unable-to-launch-elastic-search-in-rhel7-server-after-installation/5772/2 "2021-04-27T17:34:20Z")

</div>

> [@bharathsharmaja](#):
>
> Apr 27 11:55:20 choxxxxxxxxx systemd-entrypoint[6738]: at org.elasticsearch.tools.launchers.JvmOption.flagsFinal(JvmOption.java:119)

The logs might provide more insight, but it looks like some jvm opts are not happy.

---

<div class="post-metadata">

**Author:** ![bharathsharmaja](https://avatars.discourse-cdn.com/v4/letter/b/a3d4f5/32.png) [@bharathsharmaja](https://forum.opensearch.org/u/bharathsharmaja)\
**Post date:** [April 27, 2021, 5:36pm UTC](https://forum.opensearch.org/t/unable-to-launch-elastic-search-in-rhel7-server-after-installation/5772/3 "2021-04-27T17:36:06Z")

</div>

i am using open JDL Zulu 11, cannot be a compatibility issue right ?
