# Trouble in connecting kibana on AWS EC2 to AWS ES service

**URL:** <https://forum.opensearch.org/t/trouble-in-connecting-kibana-on-aws-ec2-to-aws-es-service/3317>\
**Category:** Security\
**Created:** [July 14, 2020, 10:50am UTC](https://forum.opensearch.org/t/trouble-in-connecting-kibana-on-aws-ec2-to-aws-es-service/3317 "2020-07-14T10:50:41Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![nrmohta](https://avatars.discourse-cdn.com/v4/letter/n/a3d4f5/32.png) [@nrmohta](https://forum.opensearch.org/u/nrmohta)\
**Post date:** [July 14, 2020, 10:50am UTC](https://forum.opensearch.org/t/trouble-in-connecting-kibana-on-aws-ec2-to-aws-es-service/3317/1 "2020-07-14T10:50:41Z")

</div>

Hello All,

We have created AWS ES domain with fine grain control enabled and master user (for basic auth). I am able to log-in to AWS kibana (which comes by default with ES) using master user credential.

Now I am trying to setup external kibana on EC2 which is pointing to AWS ES.  
In kibana.yml I have configured  
elasticsearch.hosts: https: AWS ES Endpoint:443  
elasticsearch.username: master user username  
elasticsearch.password: master user password

Now while starting kibana I got below logs

log [11:19:47.686] [info][OpenDistro Security Migration] Starting tenant migration  
error [11:19:47.700] [error][migration] AuthenticationError  
at wrapElasticsearchError (/home/ubuntu/opendistroforelasticsearch-kibana/plugins/opendistro\_security/lib/backend/errors/wrap\_elasticsearch\_error.js:36:12)  
at SecurityBackend.getTenantInfoWithInternalUser (/home/ubuntu/opendistroforelasticsearch-kibana/plugins/opendistro\_security/lib/backend/opendistro\_security.js:259:19)  
at process.\_tickCallback (internal/process/next\_tick.js:68:7)  
log [11:19:47.716] [info][status][plugin:opendistro\_security@7.4.2] Status changed from yellow to yellow - Tenant indices migration failed

Any pointer what I am missing here ?

---

<div class="post-metadata">

**Author:** ![abhinav](https://sea1.discourse-cdn.com/flex019/user_avatar/forum.opensearch.org/abhinav/32/707_2.png) [@abhinav](https://forum.opensearch.org/u/abhinav)\
**Post date:** [July 16, 2020, 7:31am UTC](https://forum.opensearch.org/t/trouble-in-connecting-kibana-on-aws-ec2-to-aws-es-service/3317/2 "2020-07-16T07:31:08Z")

</div>

@nrmohta Did you find the solution?

---

<div class="post-metadata">

**Author:** ![hanspro](https://avatars.discourse-cdn.com/v4/letter/h/8e8cbc/32.png) [@hanspro](https://forum.opensearch.org/u/hanspro)\
**Post date:** [August 13, 2020, 11:40am UTC](https://forum.opensearch.org/t/trouble-in-connecting-kibana-on-aws-ec2-to-aws-es-service/3317/3 "2020-08-13T11:40:41Z")

</div>

Try this

```auto
$ sudo vi /etc/kibana/kibana.yml
....
opendistro_security.multitenancy.enabled: false
...

$ sudo systemctl restart kibana

```

[Reference](https://github.com/opendistro-for-elasticsearch/security-kibana-plugin/issues/1)

Pros: Your Kibana will work.  
Cons: Multi-Tenancy is disabled.

---

<div class="post-metadata">

**Author:** ![devops](https://avatars.discourse-cdn.com/v4/letter/d/e99b99/32.png) [@devops](https://forum.opensearch.org/u/devops)\
**Post date:** [September 7, 2020, 10:31pm UTC](https://forum.opensearch.org/t/trouble-in-connecting-kibana-on-aws-ec2-to-aws-es-service/3317/4 "2020-09-07T22:31:10Z")

</div>

Hi @nrmohta @hanspro - We are also facing exact same issue but we do want multi-tenancy enabled for our Kibana running on EC2. Do we know how we can solve this issue?

---

<div class="post-metadata">

**Author:** ![dtakis](https://avatars.discourse-cdn.com/v4/letter/d/c89c15/32.png) [@dtakis](https://forum.opensearch.org/u/dtakis)\
**Post date:** [January 6, 2021, 11:40pm UTC](https://forum.opensearch.org/t/trouble-in-connecting-kibana-on-aws-ec2-to-aws-es-service/3317/5 "2021-01-06T23:40:26Z")

</div>

we too! This is not normal or expected behaviour

using Kibana Open Distro 1.9.0 on AWS Elasticsearch Open Distro 7.8
