# OpenSearch 3.7.0 fails to start

**URL:** <https://forum.opensearch.org/t/opensearch-3-7-0-fails-to-start/28207>\
**Category:** OpenSearch\
**Tags:** troubleshoot, configure, install\
**Created:** [July 17, 2026, 7:00pm UTC](https://forum.opensearch.org/t/opensearch-3-7-0-fails-to-start/28207 "2026-07-17T19:00:48Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![User26](https://avatars.discourse-cdn.com/v4/letter/u/7993a0/32.png) [@User26](https://forum.opensearch.org/u/User26)\
**Post date:** [July 17, 2026, 7:00pm UTC](https://forum.opensearch.org/t/opensearch-3-7-0-fails-to-start/28207/1 "2026-07-17T19:00:48Z")

</div>

OpenSearch 3.7.0 fails to start. I have Almalinux 10 installed. I needed OpenSearch for magento 2.

**Describe the issue** :

When run the command: sudo systemctl start opensearch and you will see: Job for opensearch.service failed because the control process exited with error code.  
See “systemctl status opensearch.service” and “journalctl -xeu opensearch.service” for details.

What I need to do so it start?

---

<div class="post-metadata">

**Author:** ![User26](https://avatars.discourse-cdn.com/v4/letter/u/7993a0/32.png) [@User26](https://forum.opensearch.org/u/User26)\
**Post date:** [July 18, 2026, 6:48pm UTC](https://forum.opensearch.org/t/opensearch-3-7-0-fails-to-start/28207/2 "2026-07-18T18:48:23Z")

</div>

I resolved the issues, so it start now.

/etc/sysconfig/opensearch

OPENSEARCH\_JAVA\_OPTS= **“-Djava.io.tmpdir=/var/lib/opensearch/tmp”**

/etc/opensearch/jvm.options

**-Xms12g  
-Xmx12g**

If there is still something wrong with the configuration, please let me know.

---

<div class="post-metadata">

**Author:** ![Yanlin](https://sea1.discourse-cdn.com/flex019/user_avatar/forum.opensearch.org/yanlin/32/10286_2.png) [@Yanlin](https://forum.opensearch.org/u/Yanlin)\
**Post date:** [July 20, 2026, 4:51pm UTC](https://forum.opensearch.org/t/opensearch-3-7-0-fails-to-start/28207/3 "2026-07-20T16:51:09Z")

</div>

Hi @User26, welcome to the OpenSearch community and glad to hear that OpenSearch is starting now.

From the logs, it appears that the Security plugin is installed and enabled, but the SSL/TLS configuration has not been completed.  
You can also confirm Security plugin state by running the below command:

```bash
/usr/share/opensearch/bin/opensearch-plugin list

```

The Security plugin errors still need to be addressed. To configure security plugin please use install\_demo\_configuration.sh script or use the example from OpenSearch documentation.  
`https://docs.opensearch.org/latest/security/configuration/yaml/#opensearchyml`

To use demo configuration script, please run the below commands.

```bash
export OPENSEARCH_INITIAL_ADMIN_PASSWORD='<strong-password>'
cd /usr/share/opensearch/plugins/opensearch-security/tools
./install_demo_configuration.sh

```

Follow the terminal prompts to complete the setup.  
For more details, please refer to:  
`https://docs.opensearch.org/latest/security/getting-started/#setting-up-the-demo-configuration`

To better understand your setup, could you clarify what you’re trying to achieve? Is this intended to be a single-node deployment? Or are you planning to build a multi-node cluster?
