# Fluentbit rejected\_execution\_exception error

**URL:** https://forum.opensearch.org/t/fluentbit-rejected-execution-exception-error/14048
**Category:** OpenSearch
**Created:** [April 20, 2023, 10:04am UTC](https://forum.opensearch.org/t/fluentbit-rejected-execution-exception-error/14048 "2023-04-20T10:04:00Z")
**Posts on this page:** 5
**Page:** 1

<div class="post-metadata">

### Author: ![tibz7](https://avatars.discourse-cdn.com/v4/letter/t/a8b319/32.png) [@tibz7](https://forum.opensearch.org/u/tibz7)
#### Post date: [April 20, 2023, 10:04am UTC](https://forum.opensearch.org/t/fluentbit-rejected-execution-exception-error/14048/1 "2023-04-20T10:04:00Z")

</div>

Hello, when sending logs via fluentbit to opensearch I’m getting a lot of these messages:

```auto
Apr 20 09:36:55 fluentbit-static02 td-agent-bit[4487]: [2023/04/20 09:36:55] [error] [output:opensearch:opensearch.2] HTTP status=429 URI=/_bulk, response:
Apr 20 09:36:55 fluentbit-static02 td-agent-bit[4487]: {"error":{"root_cause":[{"type":"rejected_execution_exception","reason":"rejected execution of coordinating operation [coordinating_and_primary_bytes=1717946997, replica_bytes=0, all_bytes=1717946997, coordinating_operation_bytes=2764011, max_coordinating_and_primary_bytes=1717986918]"}],"type":"rejected_execution_exception","reason":"rejected execution of coordinating operation [coordinating_and_primary_bytes=1717946997, replica_bytes=0, all_bytes=1717946997, coordinating_operation_bytes=2764011, max_coordinating_and_primary_bytes=1717986918]"},"status":429}
Apr 20 09:36:55 fluentbit-static02 td-agent-bit[4487]: [2023/04/20 09:36:55] [warn] [engine] chunk '4487-1681983401.821589894.flb' cannot be retried: task_id=141, input=tail.5 > output=opensearch.2

```

I dont really understand the root cause and have no idea of the potential fix.  
also my opensearch-dashboard is getting slow, I assume because opensearch has problem to ingest data.  
but previously the same server running elasticsearch + filebeat had no problem handling the exact same logs data

---

<div class="post-metadata">

### Author: ![dtaivpp](https://sea1.discourse-cdn.com/flex019/user_avatar/forum.opensearch.org/dtaivpp/32/2814_2.png) [@dtaivpp](https://forum.opensearch.org/u/dtaivpp)
#### Post date: [April 21, 2023, 7:25pm UTC](https://forum.opensearch.org/t/fluentbit-rejected-execution-exception-error/14048/2 "2023-04-21T19:25:04Z")

</div>

So a quick look and this is what I am seeing. 429 is a too many requests status. That with the `rejected_execution_exception` makes me think that you are sending too much data too fast to the `_bulk` endpoint and its exhausting your threadpool.

What does your cluster look like currently? Are you running a single/multiple nodes?

---

<div class="post-metadata">

### Author: ![gaobinlong](https://sea1.discourse-cdn.com/flex019/user_avatar/forum.opensearch.org/gaobinlong/32/5242_2.png) [@gaobinlong](https://forum.opensearch.org/u/gaobinlong)
#### Post date: [April 23, 2023, 6:34am UTC](https://forum.opensearch.org/t/fluentbit-rejected-execution-exception-error/14048/3 "2023-04-23T06:34:11Z")

</div>

Seems that the indexing pressure limit is reached, when the inflight indexing requests consume too much memory, OpenSearch will reject new indexing requests, the limit defaults to 10% of JVM heap, maybe you can increase the memory of JVM heap in your cluster, or reducing the batch size when bulking in the client-side, i.e. fluent-bit. OpenSearch does not document this feature, take a look at this:[Indexing pressure | Elasticsearch Guide [7.10] | Elastic](https://www.elastic.co/guide/en/elasticsearch/reference/7.10/index-modules-indexing-pressure.html#index-modules-indexing-pressure).

---

<div class="post-metadata">

### Author: ![bbarani](https://avatars.discourse-cdn.com/v4/letter/b/f475e1/32.png) [@bbarani](https://forum.opensearch.org/u/bbarani)
#### Post date: [April 23, 2023, 11:45pm UTC](https://forum.opensearch.org/t/fluentbit-rejected-execution-exception-error/14048/4 "2023-04-23T23:45:29Z")

</div>

You can also refer to OpenSearch blog on indexing back pressure [here](https://opensearch.org/blog/shard-indexing-backpressure-in-opensearch/#:~:text=Indexing%20backpressure%20takes%20effect%20when,by%20indexing%20backpressure%20is%20fair)

---

<div class="post-metadata">

### Author: ![tibz7](https://avatars.discourse-cdn.com/v4/letter/t/a8b319/32.png) [@tibz7](https://forum.opensearch.org/u/tibz7)
#### Post date: [April 24, 2023, 7:10am UTC](https://forum.opensearch.org/t/fluentbit-rejected-execution-exception-error/14048/5 "2023-04-24T07:10:05Z")

</div>

oh perfect thats what i was trying too! thank you I will have a look!
