# Error every reboot: Not yet initialized (you may need to run securityadmin

**URL:** <https://forum.opensearch.org/t/error-every-reboot-not-yet-initialized-you-may-need-to-run-securityadmin/4198>\
**Category:** Security\
**Created:** [November 14, 2020, 3:00pm UTC](https://forum.opensearch.org/t/error-every-reboot-not-yet-initialized-you-may-need-to-run-securityadmin/4198 "2020-11-14T15:00:44Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![tru64jurus](https://avatars.discourse-cdn.com/v4/letter/t/85e7bf/32.png) [@tru64jurus](https://forum.opensearch.org/u/tru64jurus)\
**Post date:** [November 14, 2020, 3:00pm UTC](https://forum.opensearch.org/t/error-every-reboot-not-yet-initialized-you-may-need-to-run-securityadmin/4198/1 "2020-11-14T15:00:44Z")

</div>

I have 3 node cluster running latest 1.11.0. Every time I reboot any node I get this errors for 20 minutes then it recovers and I can login using active directory credentials. During this kibana is not accessible. I have initialized security before and use AD as ldap backend.

Any help is appreciated

Thanks

kibana error: Kibana server is not ready yet

ES error: Not yet initialized (you may need to run securityadmin)

---

<div class="post-metadata">

**Author:** ![Hari](https://sea1.discourse-cdn.com/flex019/user_avatar/forum.opensearch.org/hari/32/893_2.png) [@Hari](https://forum.opensearch.org/u/Hari)\
**Post date:** [February 4, 2021, 5:00pm UTC](https://forum.opensearch.org/t/error-every-reboot-not-yet-initialized-you-may-need-to-run-securityadmin/4198/2 "2021-02-04T17:00:11Z")

</div>

I face the same error too. OD security is already initialized.

On every restart when a node tries to join back the cluster, I get this error.  
Kibana and any client connected to ES fails with the same error.

Any pointers would be helpful. Thanks.

---

<div class="post-metadata">

**Author:** ![gunnar](https://avatars.discourse-cdn.com/v4/letter/g/ed655f/32.png) [@gunnar](https://forum.opensearch.org/u/gunnar)\
**Post date:** [March 17, 2021, 1:27pm UTC](https://forum.opensearch.org/t/error-every-reboot-not-yet-initialized-you-may-need-to-run-securityadmin/4198/3 "2021-03-17T13:27:38Z")

</div>

Hello, I get that error too (4 data / 3 master nodes, 1.12.0) and as Hari said “OD security is already initialized”. Only if taking down all nodes and restarting one after the other the cluster recovers (without running securityadmin).  
Please help! TNXIA!

---

<div class="post-metadata">

**Author:** ![Stephy](https://avatars.discourse-cdn.com/v4/letter/s/f4b2a3/32.png) [@Stephy](https://forum.opensearch.org/u/Stephy)\
**Post date:** [May 19, 2024, 11:02am UTC](https://forum.opensearch.org/t/error-every-reboot-not-yet-initialized-you-may-need-to-run-securityadmin/4198/4 "2024-05-19T11:02:35Z")

</div>

Same error for me too. I am using opensearch version: 2.11.0.  
Any update from anyone on this topic?
