# Elastic curator version 7 is failing to delete indices

**URL:** https://forum.opensearch.org/t/elastic-curator-version-7-is-failing-to-delete-indices/14568
**Category:** Open Source Elasticsearch and Kibana
**Created:** [June 6, 2023, 9:04am UTC](https://forum.opensearch.org/t/elastic-curator-version-7-is-failing-to-delete-indices/14568 "2023-06-06T09:04:37Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![chirumanem](https://avatars.discourse-cdn.com/v4/letter/c/22d042/32.png) [@chirumanem](https://forum.opensearch.org/u/chirumanem)
#### Post date: [June 6, 2023, 9:04am UTC](https://forum.opensearch.org/t/elastic-curator-version-7-is-failing-to-delete-indices/14568/1 "2023-06-06T09:04:37Z")

</div>

Hello all,  
We are using elasticsearch curator version 5.8.4 with opensearch 1.2.4.  
New Curator versions are being released. We could see in the curator release document that curator 7 will work with Elasticsearch 7.x and is functionally identical to 5.8.4. We uplifted curator version from 5.8.4 to 7.0.0.  
We configured curator 7 actions to delete the logs older than 1 week

```auto
actions: |
  1:
    action: delete_indices
    description: Remove logs older than 1 week
    options:
      disable_action: false
      ignore_empty_list: true
    filters:
    - filtertype: age
      source: name
      direction: older
      timestring: '%Y.%m.%d'
      unit: days
      unit_count: 7

```

**But curator 7 is failing to delete the logs and printing below error msg**

```auto
{"extra_data":{"curator":{"function":"get_client","linenum":1067,"name":"curator.utils"}},"message":"Unable to connect to Elasticsearch cluster. Error: The client noticed that the server is not Elasticsearch and we do not support this unknown product","metadata":{"container_name":"curator","namespace":"zmanrao","pod_name":"eric-data-search-engine-curator-28100537-6slmg"},"service_id":"eric-data-search-engine-curator","severity":"error","timestamp":"2023-06-06T06:17:06.512+00:00","version":"1.2.0"}
{"extra_data":{"curator":{"function":"get_client","linenum":1072,"name":"curator.utils"}},"message":"Curator cannot proceed. Exiting.","metadata":{"container_name":"curator","namespace":"zmanrao","pod_name":"eric-data-search-engine-curator-28100537-6slmg"},"service_id":"eric-data-search-engine-curator","severity":"critical","timestamp":"2023-06-06T06:17:06.512+00:00","version":"1.2.0"}
Ended with exit code 1.

```

Why curator is unable to connect to Elasticsearch cluster? Can some one explain the behavior?

Thank you

---

<div class="post-metadata">

### Author: ![shdubsh](https://avatars.discourse-cdn.com/v4/letter/s/b782af/32.png) [@shdubsh](https://forum.opensearch.org/u/shdubsh)
#### Post date: [June 6, 2023, 3:08pm UTC](https://forum.opensearch.org/t/elastic-curator-version-7-is-failing-to-delete-indices/14568/2 "2023-06-06T15:08:45Z")

</div>

[Curator will not be compatible with OpenSearch.](https://github.com/elastic/curator/issues/1617#issuecomment-1246272250)

[Index Management](https://opensearch.org/docs/latest/im-plugin/ism/index/) is Curator’s successor. For future support, this is probably the best option.

If you have to keep Curator, it would need to be forked and modified to support OpenSearch.

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/flex019/uploads/mauve_hedgehog/original/2X/3/33547ea01a5b12dcca2958411d3edd97ae2ea8c1.png) [@system](https://forum.opensearch.org/u/system)
#### Post date: [August 5, 2023, 3:09pm UTC](https://forum.opensearch.org/t/elastic-curator-version-7-is-failing-to-delete-indices/14568/3 "2023-08-05T15:09:03Z")

</div>

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.
