# Deploying filebeat error

**URL:** https://forum.opensearch.org/t/deploying-filebeat-error/8523
**Category:** Open Source Elasticsearch and Kibana
**Tags:** all-clients, releases
**Created:** [February 4, 2022, 2:35pm UTC](https://forum.opensearch.org/t/deploying-filebeat-error/8523 "2022-02-04T14:35:17Z")
**Posts on this page:** 2
**Page:** 1

<div class="post-metadata">

### Author: ![skopen](https://avatars.discourse-cdn.com/v4/letter/s/e95f7d/32.png) [@skopen](https://forum.opensearch.org/u/skopen)
#### Post date: [February 4, 2022, 2:35pm UTC](https://forum.opensearch.org/t/deploying-filebeat-error/8523/1 "2022-02-04T14:35:17Z")

</div>

Hi Team,

when we are trying to deploying filebeat in one of the server ,getting below error . may someone help me on this

ERROR [publisher\_pipeline\_output] Failed to connect to backoff(elasticsearch([https://example.com](https://example.com))):  
Connection marked as failed because the onConnect callback failed: could not connect to a compatible version of  
Elasticsearch: 400 Bad Request: {“error”:{“root\_cause”:[{“type”:“invalid\_index\_name\_exception”,“reason”:  
“Invalid index name [_license], must not start with '_'.”,“index”:“\_license”,“index\_uuid”:“_na_”}],“type”:“invalid\_index\_name\_exception”,  
“reason”:“Invalid index name [_license], must not start with '_'.”,“index”:“\_license”,“index\_uuid”:“_na_”},“status”:400}

INFO [publisher\_pipeline\_output] Attempting to reconnect to backoff(elasticsearch([https://example.com](https://example.com)) with 22 reconnect attempt(s)

Note: We install opensearch version 1.2.3 and opensearch dashboard version 1.2.0 through helm. able to open the dashboard. when we are trying using filebeat getting above error.

i want to know what is the elasticsearch version and kibana version used this opensearch version.?

---

<div class="post-metadata">

### Author: ![kris](https://sea1.discourse-cdn.com/flex019/user_avatar/forum.opensearch.org/kris/32/2208_2.png) [@kris](https://forum.opensearch.org/u/kris)
#### Post date: [February 7, 2023, 12:02am UTC](https://forum.opensearch.org/t/deploying-filebeat-error/8523/2 "2023-02-07T00:02:57Z")

</div>


