# Debian package opendistroforelasticsearch-kibana 1.0.0 does not work

**URL:** <https://forum.opensearch.org/t/debian-package-opendistroforelasticsearch-kibana-1-0-0-does-not-work/1084>\
**Category:** Build\
**Created:** [July 9, 2019, 9:02am UTC](https://forum.opensearch.org/t/debian-package-opendistroforelasticsearch-kibana-1-0-0-does-not-work/1084 "2019-07-09T09:02:17Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![Martin](https://avatars.discourse-cdn.com/v4/letter/m/73ab20/32.png) [@Martin](https://forum.opensearch.org/u/Martin)\
**Post date:** [July 9, 2019, 9:02am UTC](https://forum.opensearch.org/t/debian-package-opendistroforelasticsearch-kibana-1-0-0-does-not-work/1084/1 "2019-07-09T09:02:17Z")

</div>

Dear developers,

the Debian package of opendistroforelasticsearch-kibana **1.0.0** does not work. The kibana.yml uses a setting which was renamed in version 7.x of Kibana. The following error is written to the syslog:  
**kibana[24831]: FATAL ValidationError: child “elasticsearch” fails because [“url” is not allowed]**

The correct line must be  
**elasticsearch.hosts: [https://localhost:9200](https://localhost:9200)**  
instead of  
elasticsearch.url: [https://localhost:9200](https://localhost:9200).

It would be great if somebody could test new packages at least once before they are released.

Greetings,

Martin

---

<div class="post-metadata">

**Author:** ![nean](https://avatars.discourse-cdn.com/v4/letter/n/71e660/32.png) [@nean](https://forum.opensearch.org/u/nean)\
**Post date:** [July 11, 2019, 2:22pm UTC](https://forum.opensearch.org/t/debian-package-opendistroforelasticsearch-kibana-1-0-0-does-not-work/1084/2 "2019-07-11T14:22:19Z")

</div>

Hi Martin,

I had the same journey, but it turned out this is not ODFE related, it has something to do with the breaking changes that comes with elasticsearch and kibana major release 7 → [Breaking changes in 7.0 | Kibana Guide [7.0] | Elastic](https://www.elastic.co/guide/en/kibana/7.0/breaking-changes-7.0.html)

in my case I had to check for following syntax changes in order to get Kibana started and reachable:

`elasticsearch.hosts: https://localhost:9200`  
and  
`server.ssl.enabled: true`

But I still have issues with the upgraded cluster as “admin” suddenly doesn’t have any write permissions and not seeing the indexes, so one more riddle to solve.

thanks,  
nean

---

<div class="post-metadata">

**Author:** ![094459](https://sea1.discourse-cdn.com/flex019/user_avatar/forum.opensearch.org/094459/32/299_2.png) [@094459](https://forum.opensearch.org/u/094459)\
**Post date:** [July 17, 2019, 1:01pm UTC](https://forum.opensearch.org/t/debian-package-opendistroforelasticsearch-kibana-1-0-0-does-not-work/1084/3 "2019-07-17T13:01:39Z")

</div>

I had the same issue - downloaded and installed today and this fixed the problem for me.
