# Dashboard networks error

**URL:** https://forum.opensearch.org/t/dashboard-networks-error/14516
**Category:** OpenSearch Dashboards
**Created:** [May 31, 2023, 11:08am UTC](https://forum.opensearch.org/t/dashboard-networks-error/14516 "2023-05-31T11:08:27Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![LMaquaire](https://avatars.discourse-cdn.com/v4/letter/l/439d5e/32.png) [@LMaquaire](https://forum.opensearch.org/u/LMaquaire)
#### Post date: [May 31, 2023, 11:08am UTC](https://forum.opensearch.org/t/dashboard-networks-error/14516/1 "2023-05-31T11:08:27Z")

</div>

**Versions** (relevant - OpenSearch/Dashboard/Server OS/Browser):  
opensearch v 2.7.0  
chrome 113.0.5672.127

**Describe the issue** :  
hello,

i have few error during navigation:

- Refused to execute inline script because it violates the following Content Security Policy directive: “script-src ‘unsafe-eval’ ‘self’”. Either the ‘unsafe-inline’ keyword, a hash (‘sha256-75XtnrpDA0UHDMcl7S8lvswryIOd0RqgacRh0AMOgdk=’), or a nonce (‘nonce-…’) is required to enable inline execution.
- uncaught (in promise) TypeError: Cannot read properties of undefined (reading ‘split’)

have you some documentation about web server’s configuration to fix this issues.

thanks

---

<div class="post-metadata">

### Author: ![Gsmitt](https://sea1.discourse-cdn.com/flex019/user_avatar/forum.opensearch.org/gsmitt/32/1718_2.png) [@Gsmitt](https://forum.opensearch.org/u/Gsmitt)
#### Post date: [June 1, 2023, 12:00am UTC](https://forum.opensearch.org/t/dashboard-networks-error/14516/2 "2023-06-01T00:00:17Z")

</div>

Hey @LMaquaire

> [@LMaquaire](#):
>
> Refused to execute inline script because it violates the following Content Security Policy directive: “script-src ‘unsafe-eval’ ‘self’”.

While back I see something like this here. Note sure if this is the same type of issue.

> <https://github.com/elastic/kibana/issues/55997>
>
> \*\*Kibana version:\*\* 7.6.0
> 
> \*\*Elasticsearch version:\*\* 7.6.0
> 
> \*\*Browser versi…on:\*\* Firefox
> 
> \*\*Original install method (e.g. download page, yum, from source, etc.):\*\* BC2
> 
> \*\*Describe the bug:\*\*
> When generating a PNG/PDF report on a dashboard, the following error shows up in the Kibana logs:
> PNG:
> \`\`\`
> log \[12:47:45.097\] \[error\]\[PNG\]\[browser-driver\]\[execute\]\[headless-browser-console\]
> \[k5wg5y4h04t11d4cb7fl9e4s\]\[reporting\] Refused to execute inline script because it violates the 
> following Content Security Policy directive: "script-src 'unsafe-eval' 'self'". Either the 'unsafe-inline' 
> keyword, a hash ('sha256-P5polb1UreUSOe5V/Pv7tc+yeZuJXiOi/3fqhGsU7BE='), or a nonce 
> ('nonce-...') is required to enable inline execution.
> 
> \`\`\`
> PDF:
> \`\`\`
> log \[12:54:17.732\] \[error\]\[browser-driver\]\[execute\]\[headless-browser-console\]
> \[k5wgecud0dsi1d4cb74eypq9\]\[printable\_pdf\]\[reporting\] Refused to execute inline script because it 
> violates the following Content Security Policy directive: "script-src 'unsafe-eval' 'self'". Either the 
> 'unsafe-inline' keyword, a hash ('sha256-P5polb1UreUSOe5V/Pv7tc+yeZuJXiOi/3fqhGsU7BE='), or a 
> nonce ('nonce-...') is required to enable inline execution.
> 
> \`\`\`
> 
> \*\*Steps to reproduce:\*\*
> 1. Load sample data.
> 2. Generate a PNG report on a dashboard.
> 
> 
> There doesn't seem to be any problem caused to the display of the dashboard or the generation of the report. The same thing happens if you try to generate a report on a visualization so it doesn't seem to be tied to dashboards.
> 
> Tested with the tar.gz package on Ubuntu 18.

Stated

> “The reason you are having a problem is that it appears you have set a more restrictive Content-Security-Policy response header. Here is the default header for Kibana:”

---

<div class="post-metadata">

### Author: ![LMaquaire](https://avatars.discourse-cdn.com/v4/letter/l/439d5e/32.png) [@LMaquaire](https://forum.opensearch.org/u/LMaquaire)
#### Post date: [June 1, 2023, 8:07am UTC](https://forum.opensearch.org/t/dashboard-networks-error/14516/3 "2023-06-01T08:07:47Z")

</div>

Hey @Gsmitt ,

in fact, i have this issue on every page.
