# Bootstrap fails on OPENSEARCH\_INITIAL\_ADMIN\_PASSWORD from operator

**URL:** <https://forum.opensearch.org/t/bootstrap-fails-on-opensearch-initial-admin-password-from-operator/24758>\
**Category:** OpenSearch\
**Tags:** troubleshoot\
**Created:** [June 13, 2025, 1:09pm UTC](https://forum.opensearch.org/t/bootstrap-fails-on-opensearch-initial-admin-password-from-operator/24758 "2025-06-13T13:09:06Z")\
**Posts on this page:** 1\
**Showing post:** 2

<div class="post-metadata">

**Author:** ![pablo](https://sea1.discourse-cdn.com/flex019/user_avatar/forum.opensearch.org/pablo/32/10363_2.png) [@pablo](https://forum.opensearch.org/u/pablo)\
**Post date:** [June 13, 2025, 3:43pm UTC](https://forum.opensearch.org/t/bootstrap-fails-on-opensearch-initial-admin-password-from-operator/24758/2 "2025-06-13T15:43:55Z")

</div>

@thoth Did you follow the solution from that forum case?

> [@New Cluster - Bootstrap only failing with missing OPENSEARCH\_INITIAL\_ADMIN\_PASSWORD](https://forum.opensearch.org/t/new-cluster-bootstrap-only-failing-with-missing-opensearch-initial-admin-password/22934/2):
>
> This is fixed now, this required the below changes extraEnv: - name: OPENSEARCH\_INITIAL\_ADMIN\_PASSWORD value: password manager: extraEnv: - name: OPENSEARCH\_INITIAL\_ADMIN\_PASSWORD value: password … bootstrap: additionalConfig: OPENSEARCH\_INITIAL\_ADMIN\_PASSWORD: password … but this is now failing with Caused by: javax.net.ssl.SSLHandshakeException: Received fatal alert: bad\_certificate

You must set OPENSEARCH\_INITIAL\_ADMIN\_PASSWORD as env variable.

This is required since version 2.12.

---

_[View the full topic](https://forum.opensearch.org/t/bootstrap-fails-on-opensearch-initial-admin-password-from-operator/24758)._
