# Adding volumemount for opensearch

**URL:** <https://forum.opensearch.org/t/adding-volumemount-for-opensearch/15317>\
**Category:** Kubernetes\
**Created:** [July 28, 2023, 12:27pm UTC](https://forum.opensearch.org/t/adding-volumemount-for-opensearch/15317 "2023-07-28T12:27:48Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![ibra1](https://avatars.discourse-cdn.com/v4/letter/i/90ced4/32.png) [@ibra1](https://forum.opensearch.org/u/ibra1)\
**Post date:** [July 28, 2023, 12:27pm UTC](https://forum.opensearch.org/t/adding-volumemount-for-opensearch/15317/1 "2023-07-28T12:27:48Z")

</div>

**Versions** (relevant - OpenSearch/Dashboard/Server OS/Browser):  
2.8 for opensearch and dashboard

**Describe the issue** :  
I am trying to make the opensearch logs available on the node for fluentbit as input, I added that to helm values but seems failing to start the opensearch cluster.

**Configuration** :

```auto
extraVolumes:
  - name: opensearch-logs
    hostPath:
      path: /var/log/opensearch/logs
      type: ''
extraVolumeMounts: 
  - name: opensearch-logs
    mountPath: /usr/share/opensearch/logs

```

**Relevant Logs or Screenshots** :  
when tail the logs from pod of opensearch, I got the following:

```auto
Enabling OpenSearch Security Plugin
Enabling execution of OPENSEARCH_HOME/bin/opensearch-performance-analyzer/performance-analyzer-agent-cli for OpenSearch Performance Analyzer Plugin
opensearch-docker-entrypoint.sh: line 61: /usr/share/opensearch/logs/PerformanceAnalyzer.log: Permission denied
Exception in thread "main" java.lang.RuntimeException: starting java failed with [1]
output:
[0.000s][error][logging] Error opening log file 'logs/gc.log': Permission denied
[0.000s][error][logging] Initialization of output 'file=logs/gc.log' using options 'filecount=32,filesize=64m' failed.
error:
Invalid -Xlog option '-Xlog:gc*,gc+age=trace,safepoint:file=logs/gc.log:utctime,pid,tags:filecount=32,filesize=64m', see error log for details.
Error: Could not create the Java Virtual Machine.
Error: A fatal exception has occurred. Program will exit.
        at org.opensearch.tools.launchers.JvmErgonomics.flagsFinal(JvmErgonomics.java:125)
        at org.opensearch.tools.launchers.JvmErgonomics.finalJvmOptions(JvmErgonomics.java:87)
        at org.opensearch.tools.launchers.JvmErgonomics.choose(JvmErgonomics.java:70)
        at org.opensearch.tools.launchers.JvmOptionsParser.jvmOptions(JvmOptionsParser.java:150)
        at org.opensearch.tools.launchers.JvmOptionsParser.main(JvmOptionsParser.java:108)

```

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/flex019/uploads/mauve_hedgehog/original/2X/3/33547ea01a5b12dcca2958411d3edd97ae2ea8c1.png) [@system](https://forum.opensearch.org/u/system)\
**Post date:** [September 26, 2023, 12:28pm UTC](https://forum.opensearch.org/t/adding-volumemount-for-opensearch/15317/2 "2023-09-26T12:28:46Z")

</div>

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.
