# Cross-Cluster Replication

**URL:** https://forum.opensearch.org/c/plugins/cross-cluster-replication/53.md?page=2

[Latest](https://forum.opensearch.org/latest.md) · [Categories](https://forum.opensearch.org/categories.md) · [Tags](https://forum.opensearch.org/tags.md)

**Page:** 3

---

## [Replication failed](https://forum.opensearch.org/t/replication-failed/8023)

<div class="topic-metadata">

**Author:** [@stdmje](https://forum.opensearch.org/u/stdmje)\
**Replies:** 7\
**Last updated:** [January 28, 2022, 7:44am UTC](https://forum.opensearch.org/t/replication-failed/8023 "2022-01-28T07:44:33Z")

</div>

Hello, I have found that sometimes, if a replica node restarts when applying changes from the master, the replication fails. Since i am running dev and staging environments in Preemptible k8s nodes, this is really anno…

---

## [How to go about Cross-cluster replication](https://forum.opensearch.org/t/how-to-go-about-cross-cluster-replication/8335)

<div class="topic-metadata">

**Author:** [@sandy381](https://forum.opensearch.org/u/sandy381)\
**Replies:** 1\
**Last updated:** [January 19, 2022, 7:21pm UTC](https://forum.opensearch.org/t/how-to-go-about-cross-cluster-replication/8335 "2022-01-19T19:21:14Z")

</div>

Hi, How to go about cross-cluster replication? Is it available in Opendistro and how to go about it? Is it possible to replicate from Elasticsearch to Opendistro & vice-versa?

---

## [Error on resume replication](https://forum.opensearch.org/t/error-on-resume-replication/7964)

<div class="topic-metadata">

**Author:** [@stdmje](https://forum.opensearch.org/u/stdmje)\
**Replies:** 6\
**Last updated:** [December 16, 2021, 10:41am UTC](https://forum.opensearch.org/t/error-on-resume-replication/7964 "2021-12-16T10:41:16Z")

</div>

Hi, I have found something weird using 1.2.0. I start the replication, everything works fine but if i pause it, when i resume it i got an error and if i check the status, looks like it’s running but the follower checkp…

---

## [Encountered a failure while executing in org.opensearch.replication.action.changes.GetChangesRequest](https://forum.opensearch.org/t/encountered-a-failure-while-executing-in-org-opensearch-replication-action-changes-getchangesrequest/7941)

<div class="topic-metadata">

**Author:** [@stdmje](https://forum.opensearch.org/u/stdmje)\
**Replies:** 2\
**Last updated:** [December 15, 2021, 9:21am UTC](https://forum.opensearch.org/t/encountered-a-failure-while-executing-in-org-opensearch-replication-action-changes-getchangesrequest/7941 "2021-12-15T09:21:25Z")

</div>

Hi, Using opensearch 1.2.0 i see several warns in the logs like the following: \[2021-12-10T08:32:44,016\]\[WARN \]\[o.o.r.t.s.ShardReplicationTask\] \[opensearch-replica-master-1\] \[cadence-visibility\]\[4\] Encountered a failur…

---

## [CCR error "Unable to initiate restore call for " on start replication](https://forum.opensearch.org/t/ccr-error-unable-to-initiate-restore-call-for-on-start-replication/7879)

<div class="topic-metadata">

**Author:** [@ptrujillo](https://forum.opensearch.org/u/ptrujillo)\
**Replies:** 2\
**Last updated:** [December 14, 2021, 5:18pm UTC](https://forum.opensearch.org/t/ccr-error-unable-to-initiate-restore-call-for-on-start-replication/7879 "2021-12-14T17:18:26Z")

</div>

I have installed two instances of opensearch with CCR following the steps in the following link Get started - OpenSearch documentation The “/\_remote/info” command executed on the follower cluster returns correct: {“Clu…

---

## [Hot/warm on CC follower](https://forum.opensearch.org/t/hot-warm-on-cc-follower/7831)

<div class="topic-metadata">

**Author:** [@Semir](https://forum.opensearch.org/u/Semir)\
**Replies:** 2\
**Last updated:** [December 1, 2021, 10:22pm UTC](https://forum.opensearch.org/t/hot-warm-on-cc-follower/7831 "2021-12-01T22:22:11Z")

</div>

Hi there, Im trying to figure out if it is possible to use hot/warm architecture only on the follower node? I mean I have a central cluster where my application runs. And several clusters that only ingest data, then I’…

---

## [CCR not working](https://forum.opensearch.org/t/ccr-not-working/7210)

<div class="topic-metadata">

**Author:** [@stdmje](https://forum.opensearch.org/u/stdmje)\
**Replies:** 5\
**Last updated:** [November 30, 2021, 7:34am UTC](https://forum.opensearch.org/t/ccr-not-working/7210 "2021-11-30T07:34:07Z")

</div>

Hello, I am testing Opensearch 1.1.0 and followed the docs in order to get CCR working but i get an error when trying to start it. Start command: curl --cert tls.crt --key tls.key --cacert ca.crt -XPUT -k -H 'Content-…

---

## [Opensearch change the owner of snapshots file](https://forum.opensearch.org/t/opensearch-change-the-owner-of-snapshots-file/7315)

<div class="topic-metadata">

**Author:** [@chenqi](https://forum.opensearch.org/u/chenqi)\
**Replies:** 1\
**Last updated:** [October 25, 2021, 4:23am UTC](https://forum.opensearch.org/t/opensearch-change-the-owner-of-snapshots-file/7315 "2021-10-25T04:23:30Z")

</div>

Excuse me， when I try to create a \_snapshots index for my cluster using the flowing code: PUT /\_snapshot/backup\_name { “type”: “fs”, “settings”: { “location”: “location\_file”, “compress”: true } } I failed and I…

---

## [Install Cross Cluster Replication on Opensearch](https://forum.opensearch.org/t/install-cross-cluster-replication-on-opensearch/6960)

<div class="topic-metadata">

**Author:** [@dimitris](https://forum.opensearch.org/u/dimitris)\
**Replies:** 2\
**Last updated:** [September 8, 2021, 11:16am UTC](https://forum.opensearch.org/t/install-cross-cluster-replication-on-opensearch/6960 "2021-09-08T11:16:05Z")

</div>

Hello all, I have a question regarding installing the cross cluster plugin on my new OpenSearch Nodes. Recently, i managed to install cross-cluster-replication plugin on opendistro by following this handbook. So far so…

---

## [Replication on existing index](https://forum.opensearch.org/t/replication-on-existing-index/6520)

<div class="topic-metadata">

**Author:** [@swastiksen](https://forum.opensearch.org/u/swastiksen)\
**Replies:** 4\
**Last updated:** [July 26, 2021, 3:58am UTC](https://forum.opensearch.org/t/replication-on-existing-index/6520 "2021-07-26T03:58:15Z")

</div>

I an trying to replicate data on an existing index… but it does not work. Below is the example. Leader has index-1 Follower has index-1 I start replication for index-1 from leader to follower, but replication does not…

---

## [Unable to start cross cluster replication](https://forum.opensearch.org/t/unable-to-start-cross-cluster-replication/5863)

<div class="topic-metadata">

**Author:** [@swastiksen](https://forum.opensearch.org/u/swastiksen)\
**Replies:** 2\
**Last updated:** [July 15, 2021, 7:00am UTC](https://forum.opensearch.org/t/unable-to-start-cross-cluster-replication/5863 "2021-07-15T07:00:45Z")

</div>

I am getting below error when trying to start replication using the curl command. I have installed the cross cluster plugin on both the clusters. I am able to cross cluster connectivity as mentioned in step (cross-clus…

---

## [Unable to install CCR plugin or install via example](https://forum.opensearch.org/t/unable-to-install-ccr-plugin-or-install-via-example/6429)

<div class="topic-metadata">

**Author:** [@BlackMetalz](https://forum.opensearch.org/u/BlackMetalz)\
**Replies:** 5\
**Last updated:** [July 14, 2021, 10:45am UTC](https://forum.opensearch.org/t/unable-to-install-ccr-plugin-or-install-via-example/6429 "2021-07-14T10:45:55Z")

</div>

Hi I followed the guide here for testing: https://opendistro.github.io/for-elasticsearch/blog/releases/2021/02/announcing-ccr/ This step isn’t working since the link is not found: RUN /usr/share/elasticsearch/bin/elast…

---

## [No user found for indices:data/read/opendistro/replication/changes](https://forum.opensearch.org/t/no-user-found-for-indices-data-read-opendistro-replication-changes/5545)

<div class="topic-metadata">

**Author:** [@bartlettjh](https://forum.opensearch.org/u/bartlettjh)\
**Replies:** 5\
**Last updated:** [July 8, 2021, 7:57am UTC](https://forum.opensearch.org/t/no-user-found-for-indices-data-read-opendistro-replication-changes/5545 "2021-07-08T07:57:53Z")

</div>

Hi, When attempting to start cross cluster replication on an index, I’m getting this error written out the the follower logs. I get a 200 code back when making the start replication request however. \[ERROR\] \[c.a.e.r.t.…

---

## [Replication stats](https://forum.opensearch.org/t/replication-stats/5896)

<div class="topic-metadata">

**Author:** [@swastiksen](https://forum.opensearch.org/u/swastiksen)\
**Replies:** 0\
**Last updated:** [May 10, 2021, 5:08pm UTC](https://forum.opensearch.org/t/replication-stats/5896 "2021-05-10T17:08:33Z")

</div>

Hi, Is there any way to fond out below stats for replication? What is the replication rate? The time stamp to which the records have been replicated? Are there any logs printed for replication? Also if the follower f…

---

## [Unable to install crosscluster replication plugin for custom Open Distro for Elasticsearch clusters](https://forum.opensearch.org/t/unable-to-install-crosscluster-replication-plugin-for-custom-open-distro-for-elasticsearch-clusters/5849)

<div class="topic-metadata">

**Author:** [@swastiksen](https://forum.opensearch.org/u/swastiksen)\
**Replies:** 3\
**Last updated:** [May 6, 2021, 8:50pm UTC](https://forum.opensearch.org/t/unable-to-install-crosscluster-replication-plugin-for-custom-open-distro-for-elasticsearch-clusters/5849 "2021-05-06T20:50:09Z")

</div>

I am trying to install cross cluster replication plugin on my existing opendistro elastic cluster which is on a server which does not have access to internet. I tried to download the zip file (https://github.com/opendis…

---

## [Rollup Up Support](https://forum.opensearch.org/t/rollup-up-support/5125)

<div class="topic-metadata">

**Author:** [@docme](https://forum.opensearch.org/u/docme)\
**Replies:** 0\
**Last updated:** [February 25, 2021, 6:45pm UTC](https://forum.opensearch.org/t/rollup-up-support/5125 "2021-02-25T18:45:40Z")

</div>

Hello Thank you very much for developing Cross Cluster Replication. In reviewing the documentation, the Aggregated Reports feature suggests that the ‘follower’ clusters can roll up reports to the to the central/leader …

---

## [Cross Cluster Replication - Roadmap item?](https://forum.opensearch.org/t/cross-cluster-replication-roadmap-item/4366)

<div class="topic-metadata">

**Author:** [@Mr\_Hedgehog](https://forum.opensearch.org/u/Mr_Hedgehog)\
**Replies:** 5\
**Last updated:** [February 22, 2021, 8:36pm UTC](https://forum.opensearch.org/t/cross-cluster-replication-roadmap-item/4366 "2021-02-22T20:36:57Z")

</div>

Hello, I have a question regarding Cross Cluster Replication. Am I correct in thinking that this feature has not yet been implemented into ODFE (to version 1.11) - but is on the Roadmap? I see from the Announcment chan…

[Previous page](https://forum.opensearch.org/c/plugins/cross-cluster-replication/53.md?page=1)
