# Cross-Cluster Replication

**URL:** https://forum.opensearch.org/c/plugins/cross-cluster-replication/53.md

[Latest](https://forum.opensearch.org/latest.md) · [Categories](https://forum.opensearch.org/categories.md) · [Tags](https://forum.opensearch.org/tags.md)

---

## [About the Cross-Cluster Replication category](https://forum.opensearch.org/t/about-the-cross-cluster-replication-category/5053)

<div class="topic-metadata">

**Author:** [@searchymcsearchface](https://forum.opensearch.org/u/searchymcsearchface)\
**Replies:** 0\
**Last updated:** [February 21, 2021, 6:07pm UTC](https://forum.opensearch.org/t/about-the-cross-cluster-replication-category/5053 "2021-02-21T18:07:15Z")

</div>

Discussion area for the cross-cluster replication plugin, which lets you replicate indexes, mappings, and metadata from one OpenSearch cluster to another.

---

## [CCR and Snapshot](https://forum.opensearch.org/t/ccr-and-snapshot/28267)

<div class="topic-metadata">

**Author:** [@farman](https://forum.opensearch.org/u/farman)\
**Replies:** 1\
**Last updated:** [September 24, 2026, 1:35pm UTC](https://forum.opensearch.org/t/ccr-and-snapshot/28267 "2026-09-24T13:35:17Z")

</div>

Versions (relevant - OpenSearch/Dashboard/Server OS/Browser): Describe the issue: If CCR is configured between Leader and Follower clusters, when snapshot of Follower is taken will it also include replication specific m…

---

## [How to handle pre-existing indices using Auto-Follow](https://forum.opensearch.org/t/how-to-handle-pre-existing-indices-using-auto-follow/28289)

<div class="topic-metadata">

**Author:** [@farman](https://forum.opensearch.org/u/farman)\
**Replies:** 3\
**Last updated:** [September 24, 2026, 10:11am UTC](https://forum.opensearch.org/t/how-to-handle-pre-existing-indices-using-auto-follow/28289 "2026-09-24T10:11:14Z")

</div>

Versions (relevant - OpenSearch/Dashboard/Server OS/Browser): Describe the issue: If I am using Auto-Follow for replication, then, follower indices are created automatically based on “pattern” and “follower\_index\_patter…

---

## ["follower\_index\_pattern" missing in CCR Auto-follow documentation](https://forum.opensearch.org/t/follower-index-pattern-missing-in-ccr-auto-follow-documentation/28284)

<div class="topic-metadata">

**Author:** [@farman](https://forum.opensearch.org/u/farman)\
**Replies:** 3\
**Last updated:** [September 23, 2026, 2:12pm UTC](https://forum.opensearch.org/t/follower-index-pattern-missing-in-ccr-auto-follow-documentation/28284 "2026-09-23T14:12:37Z")

</div>

Versions (relevant - OpenSearch/Dashboard/Server OS/Browser): Describe the issue: “follower\_index\_pattern” has been introduced in OpenSearch 3.8.0 as per release notes opensearch-build/release-notes/opensearch-release-n…

---

## [CCR bootstrap of large clusters](https://forum.opensearch.org/t/ccr-bootstrap-of-large-clusters/28148)

<div class="topic-metadata">

**Author:** [@gchakkalakkal1](https://forum.opensearch.org/u/gchakkalakkal1)\
**Replies:** 1\
**Last updated:** [June 24, 2026, 11:06am UTC](https://forum.opensearch.org/t/ccr-bootstrap-of-large-clusters/28148 "2026-06-24T11:06:39Z")

</div>

Versions (relevant - OpenSearch/Dashboard/Server OS/Browser): 3.2 Describe the issue:CCR bootstrap starts successfully and begins transferring shard segment files from the leader to the follower cluster. For some larg…

---

## [Cross-Cluster Replication: Creating index pattern in standby cluster triggers un-killable, long-running search queries on primary cluster (indices\[\*\])](https://forum.opensearch.org/t/cross-cluster-replication-creating-index-pattern-in-standby-cluster-triggers-un-killable-long-running-search-queries-on-primary-cluster-indices/28138)

<div class="topic-metadata">

**Author:** [@vnovotny98](https://forum.opensearch.org/u/vnovotny98)\
**Replies:** 13\
**Last updated:** [June 22, 2026, 1:55pm UTC](https://forum.opensearch.org/t/cross-cluster-replication-creating-index-pattern-in-standby-cluster-triggers-un-killable-long-running-search-queries-on-primary-cluster-indices/28138 "2026-06-22T13:55:42Z")

</div>

Versions (relevant - OpenSearch/Dashboard/Server OS/Browser) 2.19.3 Describe the issue: Hello community, I am experiencing a severe performance issue where creating a new index pattern in our standby/backup OpenSearc…

---

## [CCR role reversal](https://forum.opensearch.org/t/ccr-role-reversal/28144)

<div class="topic-metadata">

**Author:** [@gchakkalakkal1](https://forum.opensearch.org/u/gchakkalakkal1)\
**Replies:** 0\
**Last updated:** [June 21, 2026, 1:35pm UTC](https://forum.opensearch.org/t/ccr-role-reversal/28144 "2026-06-21T13:35:22Z")

</div>

Versions (relevant - OpenSearch/Dashboard/Server OS/Browser): 3.2 Describe the issue: CCR: persist leader-\>follower checkpoint metadata to avoid full re-sync on role change. When a cluster that was previously a CCR lea…

---

## [Support of CCR for migration to a new Opensearch version](https://forum.opensearch.org/t/support-of-ccr-for-migration-to-a-new-opensearch-version/27939)

<div class="topic-metadata">

**Author:** [@farman](https://forum.opensearch.org/u/farman)\
**Replies:** 7\
**Last updated:** [March 31, 2026, 10:50am UTC](https://forum.opensearch.org/t/support-of-ccr-for-migration-to-a-new-opensearch-version/27939 "2026-03-31T10:50:43Z")

</div>

Versions (relevant - OpenSearch/Dashboard/Server OS/Browser): 2.11 and above Describe the issue: Can CCR be used to migrate data from older version of OpenSearch to a new one using Blue Green Deployment ? If so, then ho…

---

## [Cross Cluster Replication](https://forum.opensearch.org/t/cross-cluster-replication/1813)

<div class="topic-metadata">

**Author:** [@ash74268](https://forum.opensearch.org/u/ash74268)\
**Replies:** 8\
**Last updated:** [October 6, 2025, 10:35am UTC](https://forum.opensearch.org/t/cross-cluster-replication/1813 "2025-10-06T10:35:29Z")

</div>

Hello Everyone, First of all, Thank you for a great job on creating OpenDistro for Elasticsearch. It has benefited a huge number of organizations. I would like to receive a feedback from the experts on the Cross Cluste…

---

## [Unable to create Replication](https://forum.opensearch.org/t/unable-to-create-replication/26919)

<div class="topic-metadata">

**Author:** [@mohammadjafarraza](https://forum.opensearch.org/u/mohammadjafarraza)\
**Replies:** 15\
**Last updated:** [September 10, 2025, 6:44am UTC](https://forum.opensearch.org/t/unable-to-create-replication/26919 "2025-09-10T06:44:28Z")

</div>

Versions (relevant - OpenSearch/Dashboard/Server OS/Browser): Describe the issue: While configuring Cross Cluster replication and while starting we are getting below error { “error” : { “root\_cause” : \[ { “type” : …

---

## [Policy Action to Stop Replication](https://forum.opensearch.org/t/policy-action-to-stop-replication/24675)

<div class="topic-metadata">

**Author:** [@goofinator](https://forum.opensearch.org/u/goofinator)\
**Replies:** 3\
**Last updated:** [June 10, 2025, 5:20pm UTC](https://forum.opensearch.org/t/policy-action-to-stop-replication/24675 "2025-06-10T17:20:50Z")

</div>

Versions (relevant - OpenSearch/Dashboard/Server OS/Browser): Dashboard v 3.0.0 Describe the issue: Iam trying to add an action to my replication policy to stop replicating an auto-follow index so i can delete the ind…

---

## [Cross-Cluster Replication via NAT in OpenSearch 2.17.1](https://forum.opensearch.org/t/cross-cluster-replication-via-nat-in-opensearch-2-17-1/24520)

<div class="topic-metadata">

**Author:** [@vnovotny98](https://forum.opensearch.org/u/vnovotny98)\
**Replies:** 1\
**Last updated:** [May 28, 2025, 9:18am UTC](https://forum.opensearch.org/t/cross-cluster-replication-via-nat-in-opensearch-2-17-1/24520 "2025-05-28T09:18:28Z")

</div>

Version 2.17.1 Plugins installed: all-nodes opensearch-alerting 2.17.1.0 all-nodes opensearch-anomaly-detection 2.17.1.0 all-nodes opensearch-asynchronous-search 2.17.1.0 all-nodes op…

---

## [Leader certificate validation failed when setting CCR between 2 different K8s clusters](https://forum.opensearch.org/t/leader-certificate-validation-failed-when-setting-ccr-between-2-different-k8s-clusters/23078)

<div class="topic-metadata">

**Author:** [@Julio](https://forum.opensearch.org/u/Julio)\
**Replies:** 1\
**Last updated:** [January 17, 2025, 5:25pm UTC](https://forum.opensearch.org/t/leader-certificate-validation-failed-when-setting-ccr-between-2-different-k8s-clusters/23078 "2025-01-17T17:25:44Z")

</div>

Versions (relevant - OpenSearch/Dashboard/Server OS/Browser): Dashboard 2.14 Opensearch 2.11 Describe the issue: I try to setup CCR between 2 K8s clusters; the clusters have Traefik ingress, and I configure the conne…

---

## [Cross cluster replication autopaused](https://forum.opensearch.org/t/cross-cluster-replication-autopaused/19852)

<div class="topic-metadata">

**Author:** [@rd2024](https://forum.opensearch.org/u/rd2024)\
**Replies:** 0\
**Last updated:** [June 14, 2024, 2:44pm UTC](https://forum.opensearch.org/t/cross-cluster-replication-autopaused/19852 "2024-06-14T14:44:53Z")

</div>

Versions (relevant - OpenSearch/Dashboard/Server OS/Browser): opensearch-2.14.0 Describe the issue: I try to setup ccr for two single node cluster, after the initial snapshot was restored, the replication is autopause…

---

## [Cross Cluster Replication backward compatibility during cluster upgrades](https://forum.opensearch.org/t/cross-cluster-replication-backward-compatibility-during-cluster-upgrades/19692)

<div class="topic-metadata">

**Author:** [@isuru](https://forum.opensearch.org/u/isuru)\
**Replies:** 0\
**Last updated:** [June 5, 2024, 12:08am UTC](https://forum.opensearch.org/t/cross-cluster-replication-backward-compatibility-during-cluster-upgrades/19692 "2024-06-05T00:08:43Z")

</div>

Hi, Is there a backward compatibility matrix documented for opensearch cross cluster replication plugin similar to elasticsearch ? Can we safely assume that the replication will work with the previous major/minor versio…

---

## [2.13.1 compatible plugins](https://forum.opensearch.org/t/2-13-1-compatible-plugins/19035)

<div class="topic-metadata">

**Author:** [@umang-glean](https://forum.opensearch.org/u/umang-glean)\
**Replies:** 2\
**Last updated:** [April 25, 2024, 4:44pm UTC](https://forum.opensearch.org/t/2-13-1-compatible-plugins/19035 "2024-04-25T16:44:17Z")

</div>

Versions (relevant - OpenSearch/Dashboard/Server OS/Browser): OS 2.13.1 Describe the issue: We’d like to deploy OpenSearch 2.13.1 (built from source). But getting version compatibility issues with: 3.341 Exception in…

---

## [ResourceAlreadyExistsException already exist](https://forum.opensearch.org/t/resourcealreadyexistsexception-already-exist/17503)

<div class="topic-metadata">

**Author:** [@join](https://forum.opensearch.org/u/join)\
**Replies:** 2\
**Last updated:** [March 21, 2024, 8:44am UTC](https://forum.opensearch.org/t/resourcealreadyexistsexception-already-exist/17503 "2024-03-21T08:44:54Z")

</div>

Versions (relevant - OpenSearch/Dashboard/Server OS/Browser): OS: linux Distribution opensearch number: 2.3.0 Plugins version: 2.3.0.0 Describe the issue: Hi! I have two clusters, and ccr is configured on them If …

---

## [Unable to import ccr libraries in ism project](https://forum.opensearch.org/t/unable-to-import-ccr-libraries-in-ism-project/18070)

<div class="topic-metadata">

**Author:** [@shivani](https://forum.opensearch.org/u/shivani)\
**Replies:** 2\
**Last updated:** [February 28, 2024, 6:40pm UTC](https://forum.opensearch.org/t/unable-to-import-ccr-libraries-in-ism-project/18070 "2024-02-28T18:40:47Z")

</div>

Background: I’m working on an issue in ISM to add a feature in opensearch index-management plugin. For this, I need to import some classes from opensearch cross-cluster-replication project for the same. In the ism proj…

---

## [Rest API about replication failures](https://forum.opensearch.org/t/rest-api-about-replication-failures/17889)

<div class="topic-metadata">

**Author:** [@zoley](https://forum.opensearch.org/u/zoley)\
**Replies:** 0\
**Last updated:** [February 13, 2024, 6:20pm UTC](https://forum.opensearch.org/t/rest-api-about-replication-failures/17889 "2024-02-13T18:20:25Z")

</div>

Versions (relevant - OpenSearch/Dashboard/Server OS/Browser): OpenSearch version: 2.11 Describe the issue: I’m trying to setup cross-cluster replication and the replication is not starting because of this error: Cann…

---

## [Failed to build ccr plugin on es7.10 branch](https://forum.opensearch.org/t/failed-to-build-ccr-plugin-on-es7-10-branch/16703)

<div class="topic-metadata">

**Author:** [@AaronYang](https://forum.opensearch.org/u/AaronYang)\
**Replies:** 1\
**Last updated:** [January 8, 2024, 8:09am UTC](https://forum.opensearch.org/t/failed-to-build-ccr-plugin-on-es7-10-branch/16703 "2024-01-08T08:09:58Z")

</div>

Versions (relevant - OpenSearch/Dashboard/Server OS/Browser): Gradle Version : 6.8.3 OS Info : Windows 10 10.0 (amd64) JDK Version : 15 (Zulu JDK) JAVA\_HOME : C:\\Users\\…

---

## [Connection failed error when trying to start replication](https://forum.opensearch.org/t/connection-failed-error-when-trying-to-start-replication/17253)

<div class="topic-metadata">

**Author:** [@thedraketaylor](https://forum.opensearch.org/u/thedraketaylor)\
**Replies:** 0\
**Last updated:** [December 27, 2023, 1:09pm UTC](https://forum.opensearch.org/t/connection-failed-error-when-trying-to-start-replication/17253 "2023-12-27T13:09:28Z")

</div>

Versions (relevant - OpenSearch/Dashboard/Server OS/Browser): Opensearch version: 2.11.1 Server OS: Ubuntu 22.04 server Browser: Google Chrome Describe the issue: I’ve set up replication on two single node clusters …

---

## [Data pod is restarting with fatal error : java.lang.NoSuchMethodError: 'java.util.List java.util.stream.Stream.toList()](https://forum.opensearch.org/t/data-pod-is-restarting-with-fatal-error-java-lang-nosuchmethoderror-java-util-list-java-util-stream-stream-tolist/15959)

<div class="topic-metadata">

**Author:** [@sanjay](https://forum.opensearch.org/u/sanjay)\
**Replies:** 0\
**Last updated:** [September 20, 2023, 1:02pm UTC](https://forum.opensearch.org/t/data-pod-is-restarting-with-fatal-error-java-lang-nosuchmethoderror-java-util-list-java-util-stream-stream-tolist/15959 "2023-09-20T13:02:49Z")

</div>

Hi, Im using opensearch version 2.9 We have enabled Cross-Cluster replication with security enabled and trying to delete the index from the follower cluster by stopping the replication for each of the index. The data p…

---

## [CCR not able to connect with "handshake failed because connection reset"](https://forum.opensearch.org/t/ccr-not-able-to-connect-with-handshake-failed-because-connection-reset/15383)

<div class="topic-metadata">

**Author:** [@sdbruder](https://forum.opensearch.org/u/sdbruder)\
**Replies:** 2\
**Last updated:** [September 5, 2023, 6:26am UTC](https://forum.opensearch.org/t/ccr-not-able-to-connect-with-handshake-failed-because-connection-reset/15383 "2023-09-05T06:26:01Z")

</div>

Versions (relevant - OpenSearch/Dashboard/Server OS/Browser): opensearch 2.8.0 both on follower and leader, leader is docker-based, follower is k8s-based with operator. Describe the issue: We followed the CCR document…

---

## [Indices deleted in leader cluster are not deleted in follower cluster](https://forum.opensearch.org/t/indices-deleted-in-leader-cluster-are-not-deleted-in-follower-cluster/15730)

<div class="topic-metadata">

**Author:** [@maheshmr](https://forum.opensearch.org/u/maheshmr)\
**Replies:** 1\
**Last updated:** [September 4, 2023, 8:30am UTC](https://forum.opensearch.org/t/indices-deleted-in-leader-cluster-are-not-deleted-in-follower-cluster/15730 "2023-09-04T08:30:05Z")

</div>

OpenSearch version : 2.9.0 With CCR enabled and replication rule created, the indices are getting replicated from leader to follower cluster successfully. But when a index is deleted in leader cluster, the same replica…

---

## [Cross-Cluster Replicatiob Fails with Handshake error](https://forum.opensearch.org/t/cross-cluster-replicatiob-fails-with-handshake-error/15593)

<div class="topic-metadata">

**Author:** [@icduran](https://forum.opensearch.org/u/icduran)\
**Replies:** 0\
**Last updated:** [August 21, 2023, 11:24am UTC](https://forum.opensearch.org/t/cross-cluster-replicatiob-fails-with-handshake-error/15593 "2023-08-21T11:24:49Z")

</div>

Versions (relevant - OpenSearch/Dashboard/Server OS/Browser): I am using opensearch 2.8.0 on K8s cluster. Describe the issue I am trying to set a cross cluster replication on two cluster which run on k8s. When i follo…

---

## [Query on Cross cluster replication proxy mode](https://forum.opensearch.org/t/query-on-cross-cluster-replication-proxy-mode/14951)

<div class="topic-metadata">

**Author:** [@chaitra](https://forum.opensearch.org/u/chaitra)\
**Replies:** 1\
**Last updated:** [July 10, 2023, 8:11am UTC](https://forum.opensearch.org/t/query-on-cross-cluster-replication-proxy-mode/14951 "2023-07-10T08:11:48Z")

</div>

Versions (relevant - OpenSearch/Dashboard/Server OS/Browser): I am using Opensearch 2.7.0 in k8s env. Describe the issue: I want to establish cross cluster connection using proxy mode. So wanted some information about…

---

## [Query on remote\_cluster\_client role](https://forum.opensearch.org/t/query-on-remote-cluster-client-role/14927)

<div class="topic-metadata">

**Author:** [@chaitra](https://forum.opensearch.org/u/chaitra)\
**Replies:** 1\
**Last updated:** [July 3, 2023, 8:23am UTC](https://forum.opensearch.org/t/query-on-remote-cluster-client-role/14927 "2023-07-03T08:23:21Z")

</div>

Versions (relevant - OpenSearch/Dashboard/Server OS/Browser): I am using 2.7.0 Opensearch, opensearch dashboards in k8s environment. Describe the issue: From Getting started - OpenSearch documentation it is documented…

---

## [Query on Cross cluster Replication metadata store](https://forum.opensearch.org/t/query-on-cross-cluster-replication-metadata-store/14843)

<div class="topic-metadata">

**Author:** [@chaitra](https://forum.opensearch.org/u/chaitra)\
**Replies:** 1\
**Last updated:** [June 30, 2023, 2:51pm UTC](https://forum.opensearch.org/t/query-on-cross-cluster-replication-metadata-store/14843 "2023-06-30T14:51:01Z")

</div>

Versions (relevant - OpenSearch/Dashboard/Server OS/Browser): I am using 2.7.0 Opensearch, opensearch dashboards in k8s environment. Describe the issue: From the follower cluster’s cluster-manager logs I saw below inf…

---

## [CCR stopped working after 3 days, what can I do?](https://forum.opensearch.org/t/ccr-stopped-working-after-3-days-what-can-i-do/14351)

<div class="topic-metadata">

**Author:** [@szurokl](https://forum.opensearch.org/u/szurokl)\
**Replies:** 1\
**Last updated:** [June 12, 2023, 1:53am UTC](https://forum.opensearch.org/t/ccr-stopped-working-after-3-days-what-can-i-do/14351 "2023-06-12T01:53:36Z")

</div>

OpenSearch 2.4 (running in docker) I am trying to use CCR autofollow, to replicate indices. After around 3 days the replication seemingly stopped working and I can’t figure out why. I tried deleting and recreating the a…

---

## [Using CCR plugin on Elastic's distribution](https://forum.opensearch.org/t/using-ccr-plugin-on-elastics-distribution/5272)

<div class="topic-metadata">

**Author:** [@askids](https://forum.opensearch.org/u/askids)\
**Replies:** 4\
**Last updated:** [April 17, 2023, 6:32am UTC](https://forum.opensearch.org/t/using-ccr-plugin-on-elastics-distribution/5272 "2023-04-17T06:32:50Z")

</div>

hi, I just saw that CCR feature has been released as a plugin for ODFE, which is great news. We run regular distribution of Elasticsearch with basic license. Can this plugin be used with Elastic’s distribution? I unders…

[Next page](https://forum.opensearch.org/c/plugins/cross-cluster-replication/53.md?page=1)
